ASPL11beta глюки железячные

Аватар пользователя Diclam

Скачал 4х дисковую версию. Установил.
Порадовала, произодит очень приятное впечатление.

Но есть проблемы...
-Не работает звук (начинает играть и зацикливается покругу пока не прикончишь приложение звуковоспроизводящее)
-Не работает сеть, тут вообще все непонятно.
интерфейс поднимается, но данные неходят. dhcp тоже получить неможет.
пакеты в интерфейс вроде как уходят. но не возвращаются (снифер поднимал). при просмотре ifconfig указано 0 передано 0 принято
несмотря на самолично захваченые снифером уходящие пакеты.
да и свич мигает (например при ping). роутинг проверял. настроен так-же как на 10ке, там все работает.настройки интерфейса то-же проверил и не раз.

Перед этим стояла ASPL10 проблем такого рода невозникало. Железо неизменно.

AMD64 -3200попугаев
1024ram pc3200
200гб hdd ide seagate
2x CDROM(dvdram)
via 8t800pro (m/b)
vt6120 velocity (gigabit ethernet)
ati9800 video
audigy 24bit (виндами определяется как типовой лайв)
ну и еще куча фигни мелкой.

---
Вот еще что: при запуске намертво виснет сэндмайл при инициализации.
выкинул его из загрузки нафиг. тоже было и на десятке. переустанавливал раз 10 с форматированием. без идей что тому причина.

Аватар пользователя sergeil

Re: ASPL11beta глюки железячные

Цитата:
Diclam пишет:
Скачал 4х дисковую версию. Установил.
Порадовала, произодит очень приятное впечатление.

Действительно, приятный дистрибутив...

Цитата:
Но есть проблемы...
-Не работает звук (начинает играть и зацикливается покругу пока не прикончишь приложение звуковоспроизводящее)

Чем играем звук? Через что выводится звук (ALSA, OSS, aRts, ...)

Цитата:
-Не работает сеть, тут вообще все непонятно. интерфейс поднимается, но данные неходят. dhcp тоже получить неможет.

Какая сетевая?что в файле конфигурации интерфейса?
cat /etc/sysconfig/network-scripts/ifcfg-eth0

Цитата:
пакеты в интерфейс вроде как уходят. но не возвращаются (снифер поднимал). при просмотре ifconfig указано 0 передано 0 принято
несмотря на самолично захваченые снифером уходящие пакеты.

Значит не ходят. Сниффер переводит карту в смешанный режим. Что там Вы наблюдали... Похоже, что сетевой интерфейс физически поднят, но IP реквизиты на нем кривые...

Цитата:
да и свич мигает (например при ping). роутинг проверял. настроен так-же как на 10ке, там все работает. настройки интерфейса то-же проверил и не раз.

очень интересно и действительно непонятно...

Цитата:
Перед этим стояла ASPL10 проблем такого рода невозникало. Железо неизменно.

Новое ядро распознает больше оборудования. Может еще что-то еще найдено и проинициализировано? Что говорит `lspci -v`

Цитата:
Вот еще что: при запуске намертво виснет сэндмайл при инициализации. выкинул его из загрузки нафиг. тоже было и на десятке. переустанавливал раз 10 с форматированием. без идей что тому причина.

Пропишите в /etc/hosts IP адрес на имя своего хоста. Как правило, это IP адрес eth0. смотри:`hostname`, `ifconfig eth0`

Аватар пользователя lkanter

Re: ASPL11beta глюки железячные

Diclam

Цитата:
Вот еще что: при запуске намертво виснет сэндмайл при инициализации.
выкинул его из загрузки нафиг. тоже было и на десятке. переустанавливал раз 10 с форматированием. без идей что тому причина.

sendmail не грузится только в одном случае - когда машине присваивают левое имя (hostname) и забывают его привязать в /etc/hosts к одному из имеющихся на этой машине IP-адресов (например, к 127.0.0.1)

Аватар пользователя Diclam

Re: ASPL11beta глюки железячные

sergeil
провел эксперимент - отглючил бортовую сеть и воткнул забортную кривалтек8139
сеть заработала как часы.
dhcp получает быстро. с ручными параметрами тоже проблем нет.
пришел к выводу что виноват драйвер сетевухи или она встает в неподдерживаемую свичем моду (гигабит).

звук выводится через ALSA
сетевая vt6122 (via-velocity)

Значит не ходят. Сниффер переводит карту в смешанный режим. Что там Вы наблюдали... Похоже, что сетевой интерфейс физически поднят, но IP реквизиты на нем кривые...
но ведь рутер както запрос dhcp принимает от этой машины? и мак ее определяет верно?
ip реквизиты в dhcp разве не сами определяются?

GATEWAY=192.168.1.1
BOOTPROTO=none
PEERDNS=yes
IPV6INIT=no
TYPE=Ethernet
DEVICE=eth0
NETMASK=255.255.255.0
BROADCAST=192.168.1.255
IPADDR=192.168.1.5
NETWORK=192.168.1.0
ONBOOT=yes
USERCTL=yes

sendmail исправил, спасибо.

---------
Вот еще что о составе дистра:
нет sym и нет mplayer. очень грустно.
это то что пока ощутил

Аватар пользователя Diclam

Re: ASPL11beta глюки железячные

Попробовал собрать драйвер из исходников и столкнулся с:

make -C /lib/modules/2.6.14-1.1653asp/build SUBDIRS=/root/Desktop/velocityget-bin_11172005/1.22 modules
make[1]: Entering directory `/usr/src/kernels/2.6.14-1.1653asp-i686'
  CC [M]  /root/Desktop/velocityget-bin_11172005/1.22/velocity_main.o
/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c: In function ‘velocity_notify_reboot’:
/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c:1960: error: incompatible type for argument 2 of ‘velocity_suspend’
/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c: In function ‘velocity_suspend’:
/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c:2004: error: incompatible type for argument 2 of ‘pci_set_power_state’
make[2]: *** [/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.o] Ошибка 1
make[1]: *** [_module_/root/Desktop/velocityget-bin_11172005/1.22] Ошибка 2
make[1]: Leaving directory `/usr/src/kernels/2.6.14-1.1653asp-i686'

Что это значит?

Аватар пользователя rjaan

Re: ASPL11beta глюки железячные

Цитата:
Diclam писал:
. . .
но ведь рутер както запрос dhcp принимает от этой машины? и мак ее определяет верно?
ip реквизиты в dhcp разве не сами определяются?

GATEWAY=192.168.1.1
BOOTPROTO=none
PEERDNS=yes
IPV6INIT=no
TYPE=Ethernet
DEVICE=eth0
NETMASK=255.255.255.0
BROADCAST=192.168.1.255
IPADDR=192.168.1.5
NETWORK=192.168.1.0
ONBOOT=yes
USERCTL=yes

По идеи не должен, так как у Вас в переменной BOOTPROTO он не указан.
Мне кажется из всего безобразия Вам будет достаточно оставить следующие
переменные: DEVICE, ONBOOT, BOOTPROTO, PEERDNS.

DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp
PEERDNS=yes

Да не забудте посмотреть в /etc/modules.conf, что у вас установлен alias для вашей карты и eth0.

Аватар пользователя Diclam

Re: ASPL11beta глюки железячные

rjaan
не совсем правильно выразил свою мысль.
код мной указаный для статики. я понимаю что он dhcp не подберет.

проверил копированием вашего кода, результат такой-же:
8139(внешняя) поднимается и работает.
via-velocity (onboard) поднимается и неработает.

в modules.conf алиас на месте.

всетаки подозреваю драйвер карты via
как его перекомпилить правильно? (по инструкции к исходнику дает ошибку "/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c:1960: error: incompatible type for argument 2 of ‘velocity_suspend’")

Аватар пользователя rjaan

Re: ASPL11beta глюки железячные

Цитата:
Diclam писал:
"/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c:1960: error: incompatible type for argument 2 of ‘velocity_suspend’")

У Вас кажется не производится сборка velocity_main.c, в результате несовместимости типов аргументов
функций velocity_notify_reboot и pci_set_power_state, передоваемым им переменным. Так причем здесь настройки
сетевого интерфейса eth0, когда выдает ошибку компилятор при трансляции кода? В чем проблема?

make -C /lib/modules/2.6.14-1.1653asp/build SUBDIRS=/root/Desktop/velocityget-bin_11172005/1.22 modules
make[1]: Entering directory `/usr/src/kernels/2.6.14-1.1653asp-i686'
CC [M] /root/Desktop/velocityget-bin_11172005/1.22/velocity_main.o
/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c: In function ‘velocity_notify_reboot’:
/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c:1960: error: incompatible type for argument 2 of ‘velocity_suspend’
/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c: In function ‘velocity_suspend’:
/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.c:2004: error: incompatible type for argument 2 of ‘pci_set_power_state’
make[2]: *** [/root/Desktop/velocityget-bin_11172005/1.22/velocity_main.o] Ошибка 1
make[1]: *** [_module_/root/Desktop/velocityget-bin_11172005/1.22] Ошибка 2
make[1]: Leaving directory `/usr/src/kernels/2.6.14-1.1653asp-i686'

Аватар пользователя Diclam

Re: ASPL11beta глюки железячные

rjaan

проблема в том, что драйвер моей сетевой карточки из дострибутива ASP11b некорректно с ней работает (ИМХО), а попытка самостоятельной сборки драйвера из исходников с сайта Via упирается в ошибки которые выше моего понимания. Грустный

Аватар пользователя rjaan

Re: ASPL11beta глюки железячные

Цитата:
Diclam писал:
проблема в том, что драйвер моей сетевой карточки из дострибутива ASP11b некорректно с ней работает (ИМХО), а попытка самостоятельной сборки драйвера из исходников с сайта Via упирается в ошибки которые выше моего понимания.

У Вас компилятор выдает ошибку из-за несовместимости типов переменных.
Во-вторых не ужели все так плохо, что драйвер не входит в стандартную поставку ядра?
Если такового и правда нет, то Вам нужно обратится в Support Via или самому поправить ошибку.

Аватар пользователя Diclam

Re: ASPL11beta глюки железячные

Цитата:
Во-вторых не ужели все так плохо, что драйвер не входит в стандартную поставку ядра?

Есть он в стандартной поставке. Только карта с ним неработает. Интерфейс поднимается но пакеты не ходят.
Пришел к такому выводу все проверив 5 раз и заменив карточку на другую (внешнюю) которая при таких-же параметрах завелась нормально.

Аватар пользователя sergeil

Re: ASPL11beta глюки железячные

Diclam

Цитата:
audigy 24bit (виндами определяется как типовой лайв)

Хмм... Если я правильно узнал эту карту, то она так-же похожа на настоящий лайв как программный рейд на аппаратный. Какой драйвер ALSA под нее в /etc/modprobe.conf ?

Аватар пользователя Diclam

Re: ASPL11beta глюки железячные

alias char-major-116 snd
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias scsi_hostadapter1 atp870u
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0  
options snd-emu10k1 index=0  
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-emu10k1

сама карта: http://www.nix.ru/autocatalog/creative/creative_sound/SBCrAudigSB0160_19...

Мне родную сеть завести-бы еще.
В алиасах прописана, конфиги вроде правильно прописаны.
Файрвол отключен.
И что самое интересное - пакеты из карты физически уходят, ведь роутер принимает запрос dhcp.

От дестятки драйвер можно какнибудь прикрутить?

Аватар пользователя rjaan

Re: ASPL11beta глюки железячные

Цитата:
Diclam писал:
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias scsi_hostadapter1 atp870u
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
options snd-emu10k1 index=0
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-emu10k1

сама карта: http://www.nix.ru/autocatalog/creative/creative_sound/SBCrAudigSB0160_19...

Мне родную сеть завести-бы еще.

Извените, но в aliases у Вас прописаны только звуковые карты, а где alias к сетевому интерфейсу eth0 :-?

Пожалуйста, сделайте следующую операцию, как указано ниже в сл. примере

[root@rjaan ~]# dmesg | grep eth0
divert: allocating divert_blk for eth0
eth0: RealTek RTL8139 at 0xa000, 00:00:00:00:00:00, IRQ 209
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth0: no IPv6 routers present
[root@rjaan ~]#

В этом примере выводится лог загрузки ядра для сетевого интерфейса eth0.

Аватар пользователя Diclam

Re: ASPL11beta глюки железячные

alias scsi_hostadapter sata_via
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias scsi_hostadapter1 atp870u
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
options snd-emu10k1 index=0
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-emu10k1
alias char-major-81 saa7134
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
options snd-via82xx index=1
remove snd-via82xx { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx
alias eth0 8139too
alias eth1 via-velocity

полный

[root@localhost ~]# dmesg | grep eth1
eth1: VIA Networking Velocity Family Gigabit Ethernet Adapter
eth1: Ethernet Address: 00:50:8D:EF:FB:A8
eth1: no IPv6 routers present
eth1: no IPv6 routers present
[root@localhost ~]# dmesg | grep eth0
eth0: RealTek RTL8139 at 0xf8806000, 00:0d:88:2c:c1:fd, IRQ 5
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth0: no IPv6 routers present

Аватар пользователя rjaan

Re: ASPL11beta глюки железячные

Цитата:
Diclam писал:

alias eth0 8139too
alias eth1 via-velocity

[root@localhost ~]# dmesg | grep eth1
eth1: VIA Networking Velocity Family Gigabit Ethernet Adapter
eth1: Ethernet Address: 00:50:8D:EF:FB:A8
eth1: no IPv6 routers present
eth1: no IPv6 routers present
[root@localhost ~]# dmesg | grep eth0
eth0: RealTek RTL8139 at 0xf8806000, 00:0d:88:2c:c1:fd, IRQ 5
eth0: Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth0: no IPv6 routers present

Теперь у Вас должны быть два конфигурационных файлов для сетевых eth0 и eth1,
т.е. /etc/sysconfig/network-scripts/ifcfg-eth0 и /etc/sysconfig/network-scripts/ifcfg-eth1,
где в переменной DEVICE будет прописано eth0 и eth1, соответственно.
Перед тем как проэксперементировать, в файле активного сетевого интерфейса
переменную ONBOOT выставить в yes, а пассивного в no .

Сеть рекомендую перезапускать через скрипт network в init.d

[root@rjaan ~]# /etc/init.d/network status
                . . .
[root@rjaan ~]# /etc/init.d/network stop
                . . .
[root@rjaan ~]# /etc/init.d/network start
               . . .

Аргумент status позволит убедится, какие сетевые
интерфейсы будут запущены по аргументу start .

По идеи, все должно работь...

RSS-материал