*.diff как поставить

Аватар пользователя fuze

Скачал обновление на kde - оказался файл post-3.4.3-kdelibs-kjs.diff. Вопрос: что с ним делать?

Аватар пользователя sergeil

Re: *.diff как поставить

Цитата:
fuze пишет:
Скачал обновление на kde - оказался файл post-3.4.3-kdelibs-kjs.diff. Вопрос: что с ним делать?

И где Вы его взяли? Насколько я знаю, ASP не выкладываюет diff-файлы. Вам следовало качать RPM пакеты... Если обновления производятся через yum, то и качать самому ничего не нужно. Yum это сделает сам. Возможно, процесс закачки был оборван и вы наблюдаете частично закачанные данные. Попытайтесь повторить попытку обновится через yum.

Аватар пользователя keng00ru

Re: *.diff как поставить

sergeil

Цитата:
Возможно, процесс закачки был оборван и вы наблюдаете частично закачанные данные.

Точно. diff - это что-то типа результата сравнения двух версий.

Аватар пользователя fuze

Re: *.diff как поставить

Цитата:
И где Вы его взяли? Насколько я знаю, ASP не выкладываюет diff-файлы. Вам следовало качать RPM пакеты... Если обновления производятся через yum, то и качать самому ничего не нужно. Yum это сделает сам. Возможно, процесс закачки был оборван и вы наблюдаете частично закачанные данные. Попытайтесь повторить попытку обновится через yum.

Я прочитал вот эту новость:
Ошибка JavaScript позволяет перехватить управление системой, использующей KDE.
Серьезная уязвимость обнаружена в популярном программном обеспечении с открытым исходным кодом KDE. Ошибка, расцениваемая аналитической фирмой FrSIRT как «критическая», позволяет удаленному злоумышленнику получить контроль над уязвимой системой. KDE это пакет ПО рабочего стола для Linux- и Unix-систем, куда входит веб-браузер Konqueror и другие приложения.
Ошибка находится в механизме интерпретатора JavaScript, которым пользуется Konqueror и другие компоненты KDE, утверждается в опубликованном в четверг предупреждении. Чтобы воспользоваться уязвимостью, злоумышленник может сформировать специальную последовательность URI в коде UTF-8. В предупреждении FrSIRT говорится, что для того, чтобы атака достигла своей цели, пользователь атакуемого компьютера должен посетить веб-страницу злоумышленника посредством Konqueror.
Ошибка присутствует в KDE 3.2.0 и выше, включая KDE 3.5.0. Исправления уже вышли и доступны для скачивания на kde.org.

Залез на сайт KDE и скачал то что было по этой теме. Как раз это был файл post-3.4.3-kdelibs-kjs.diff. Может я че недопонял? :-?

Аватар пользователя sergeil

Re: *.diff как поставить

fuze

Цитата:
Залез на сайт KDE и скачал то что было по этой теме. Как раз это был файл post-3.4.3-kdelibs-kjs.diff. Может я че недопонял? :-?

1. Я-бы оставил это разработчикам ASPLinux. Они тоже читают новости, латают дырки в пакетах и выкладывают обновления. Кстати, версия от ASPLinux может уже содержать эту заплатку.
2. Если это заплатка на исходники, то патчить нужно исходники KDE. А если это бинарная заплатка на конкретную сборку, то она вам врят-ли подойдет. У вас сборка от ASPLinux. И она отличается от той, что на kde.org.
3. Пока не посещайте Konqueror сомнительные сайты. Попробуйте другие бровзеры.

Аватар пользователя Tigro

Re: *.diff как поставить

diff - это всего лишь патч, его нужно накладывать на исходники...

Аватар пользователя fuze

Re: *.diff как поставить

Спасибо за разъяснение! Я догадывался, но не был уверен.
Улыбка

RSS-материал