Обновление KDE из FC4

Аватар пользователя slavikVA

Есть в наличии FC4, можно ли обновить KDE пакетами из FC4, будут ли проблемы после перестановки, возможно ли в случаи неудачной установки сделать бэкап? Установлена ASP v10., KDE 3.3.1-4 asp.

Аватар пользователя Tigro

Re: обновление KDE из FC4

Увы, но в FC4 все заточено под GCC 4, так что ничего не выйдет.

Аватар пользователя DRVTiny

Re: обновление KDE из FC4

Цитата:
Увы, но в FC4 все заточено под GCC 4, так что ничего не выйдет.

А при чём тут уже откомпилированный код? Или проблема в несоместимости с библиотекой GLibC от Fedor'ы? В принципе, в данном случае могут иметь значение только привязки к изменившимся в Федоре 4 (относительно 3-й версии) импортируемым функциям общесистемных библиотек. При чём здесь компилятор?

Аватар пользователя slavaz

Re: обновление KDE из FC4

ldd /usr/bin/kde-menu |grep gcc

Проблема в этом.

Аватар пользователя sergeil

Re: обновление KDE из FC4

slavikVA

Цитата:
Установлена ASP v10., KDE 3.3.1-4 asp.

А почему не взять сразу KDE-3.5? Тем более, что есть в http://updates.msiu.ru/pack/testing10.html
Ну, или если очень хочется стабильности, то здесь ftp://ftp.asplinux.com.ua/pub/contribs/10.1/SRPMS/ и пересобрать пакеты...

Как по мне, то из федоры можна брать только системный софт, для которого кирилизация не имеет значения...

RSS-материал