Проблема с кодировками в Samba

Аватар пользователя vint

Помогите, пожалуйста. У меня установлен ASPLinux11 с кодировкой локали cp1251. Я в локальной сети, где много машин Виндовых. Некоторые пользователи вылаживают в сеть ресурсы с русскими названиями и монтировать их не получается. Например:
1. Если удаленный ресурс //server/video, то мантируется без проблем
mount -t smbfs //server/video /mnt/video -o iocharset=cp1251,codepage=cp866
и при этом корректно отображаются русские названия в примонтированном ресурсе
2. Если удаленный ресурс //server/видео, с трудом получилось примонтировать, но имена русских папок и файлов в примонтированном ресурсе некорректно отображаются

Помогите найти проблему. В каких настроечных файлах нужно править ?

Аватар пользователя woodoo

Re: Проблема с кодировками в Samba

Цитата:
vint пишет:
Помогите найти проблему. В каких настроечных файлах нужно править ?

Оставляй 1 вариант - это правильно. Имена сетевых объектов не должны иметь в названии кириллицы.
При желании - могу аргументировать.

Аватар пользователя vint

Re: Проблема с кодировками в Samba

Цитата:
woodoo пишет:

Цитата:
vint пишет:
Помогите найти проблему. В каких настроечных файлах нужно править ?

Оставляй 1 вариант - это правильно. Имена сетевых объектов не должны иметь в названии кириллицы.
При желании - могу аргументировать.

Спасибо. Я сам разобрался, даже с кириллистическими именами сетевых объектов. В smb.conf настроил. Все монтируется правильно, но есть одно но:
Например в fstab вписую //server/Фильмы /mnt/films smbfs iocharset=cp1251,codepage=cp866 0 0
На рабочем столе в KDE появляется значек сетевого ресурса. Если я его открываю, то монтируется ресурс с неправильной кодировкой, где этот скрипт монтирования не знаю, а вот если я монтирую вручную, набрав mount //server/Фильмы, все отлично монтируется с русскими именами.
Не имею понятия где эта связь значек на рабочем столе и fstab ?
Подскажите, пожалуйста

RSS-материал