Вопрос по libpq.so. Где он?

Аватар пользователя Vladimir

У меня ASP11.
Пытаюсь поставить postgresql.
Выдает:
ошибка: Неудовлетворенные зависимости:
libpq.so.4 нужен для postgresql-8.0.6-1.FC4.1.i386
Подскажите, пожалуйста, в каком rpm он находится?
rpm начинающегося на libpq нет ни на одном диске.
Заранее благодарю.

Аватар пользователя Radik

Re: Вопрос по libpq.so. Где он?

Попробуйте ввести в Google "libpq.so.4" и получите много ссылок, в том числе с указанием пакета, в котором находится требуемое.
Вариант не единственный, но помогает всегда.

Аватар пользователя rjaan

Re: Вопрос по libpq.so. Где он?

Цитата:
rrraD пишет:
Попробуйте ввести в Google "libpq.so.4" и получите много ссылок, в том числе с указанием пакета, в котором находится требуемое.
Вариант не единственный, но помогает всегда.

Зачем такие сложности, если есть локальный репозитарий или в отсутсвия оного обратится к удаленному репозитарию. К примеру у меня ASPlinux 10 ищем какой пакет нужен для установки этой библиотек, только у меня libpq.so.3, как выяснилось.

[root@home sysconfig]# yum provides libpq.so.3
Searching Packages:
Setting up Repo:  base
repomd.xml                100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 2014/2014
Importing Additional filelist information for packages
base      : ################################################## 2014/2014


postgresql-libs.i386                     7.4.2-1                base
Matched from:
/usr/lib/libpq.so.3.1
/usr/lib/libpq.so.3
libpq.so.3
[root@home sysconfig]#

Для инсталяции мне нужно лишь будет набрать

[root@home sysconfig]# yum install postgresql-libs.i386
Аватар пользователя Radik

Re: Вопрос по libpq.so. Где он?

Ну вот видите, Vladimir, стоит только захотеть, а способы найдуться... ;-)
Спасибо, rjaan!
:thanks:

Аватар пользователя Vladimir

Re: Вопрос по libpq.so. Где он?

Всем большое спасибо, особенно rjaan. Ваш совет помог.
Я только пару дней назад перешел на ASP и не знал, что есть аналог apt-get.
А в гугле я первым делом ищу Улыбка И там мне выдало, что это libpq4.0.x(чего-то там).rpm

Аватар пользователя Radik

Re: Вопрос по libpq.so. Где он?

Vladimir писал(а):
А в гугле я первым делом ищу Улыбка И там мне выдало, что это libpq4.0.x(чего-то там).rpm

Мне он выдал шестой ссылкой по счету, что для 4-ой федоры это пакет postgresql-libs-8.0.3-1.i386.rpm, а для мандривы libpq4-8.0.3-2mdk.i586.rpm.

Аватар пользователя rjaan

Re: Вопрос по libpq.so. Где он?

Цитата:
Vladimir пишет:
. . .
Я только пару дней назад перешел на ASP и не знал, что есть аналог apt-get.
. . .

На страницах Клуба имеется пара статей на эту тему:
Настройка yum mini-HOWTO
Дистрибутив ASPLinux: Создание YUM-репозитария

RSS-материал