Новые дрова на ATI 9550

Аватар пользователя ILB

Всем доброго времени суток. Теперь буду понемного *доставать* форумчан вопросами. Начнем пожалуй...
Поставил ASP 11. Есть ATI Radeon 9550. В принципе порадовала дефолтная поддержка fglrx-дров, однако на сайте ati.com обнаружил свежие дрова. Скачал rpm, вхожу в konsole ...

[ilya@localhost ~]$ su
Password:
[root@localhost ilya]# mc
[root@localhost download]# rpm -Uhv fglrx_6_8_0-8.27.10-1.i386.rpm
ошибка: Неудовлетворенные зависимости:
libexpat.so.1 нужен для fglrx_6_8_0-8.27.10-1.i386
[root@localhost download]# yum install /home/ilya/download/fglrx_6_8_0-8.27.10-1.i386.rpm
Repository updates.msiu.ru-other is listed more than once in the configuration
Setting up Install Process
Setting up repositories
base 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
Parsing package install arguments
Examining /home/ilya/download/fglrx_6_8_0-8.27.10-1.i386.rpm: fglrx_6_8_0 - 8.27.10-1.i386
Marking /home/ilya/download/fglrx_6_8_0-8.27.10-1.i386.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package fglrx_6_8_0.i386 0:8.27.10-1 set to be updated
--> Running transaction check
--> Processing Dependency: libexpat.so.1 for package: fglrx_6_8_0
--> Finished Dependency Resolution
Error: Missing Dependency: libexpat.so.1 is needed by package fglrx_6_8_0
[root@localhost download]#

Вопрос в новых дровах непринципиален, но хотелось бы знать откуда ету зависимость взять. Спасибо. :-?
З.Ы. Инсталлер (run) наверное не имеет смысла качать ?

Аватар пользователя alex_root

Re: новые дрова на ATI 9550

Эта библиотека установлена но не видима? Или её нет?
expat пакет поставить не пробовали?
Что то похожее уже
[url=https://asplinux.net/node/2128&sortname=&sortorder=&sortdays=&viewmode=flat&order=1&start=0было.[/url]

зы. И ещё, прочтите вторую половину статьи.

Аватар пользователя ILB

Re: новые дрова на ATI 9550

Цитата:
alex_root пишет:
Эта библиотека установлена но не видима? Или её нет?
expat пакет поставить не пробовали?


[root@localhost ilya]# rpm -qa | grep expat
expat-1.95.8-6
expat-devel-1.95.8-6

Аватар пользователя sergeil

Re: новые дрова на ATI 9550

ILB писал(а):
[root@localhost ilya]# rpm -qa | grep expat
expat-1.95.8-6
expat-devel-1.95.8-6

Это symlink. В пакете от ASPLinux такого нет...

Есть решение, но я не знаю, стоит ли Вам его использовать... Если что-то изначально ставится криво - то и дальше будет глючить... http://www.asteriskguru.com/tutorials/asterisk_installation_compilation_...

Цитата:
2. Possible errors and solutions

1) If you get an error like:

"libexpat.so.1: No such file or directory"

First search for the libexpat in the /usr/lib directory

# cd /usr/lib
# ls -l libexpat*

You must see something like this:

-rw-r--r-- 1 root root 160636 2005-09-09 18:58 libexpat.a
-rw-r--r-- 1 root root 706 2005-09-09 18:58 libexpat.la
lrwxrwxrwx 1 root root 17 2006-01-13 12:26 libexpat.so -> libexpat.so.0.5.0
lrwxrwxrwx 1 root root 17 2006-01-13 12:26 libexpat.so.0 -> libexpat.so.0.5.0
-rwxr-xr-x 1 root root 127428 2005-09-09 18:58 libexpat.so.0.5.0

If you don't have libexpat.so. try to install "again" the expat.
Next, create symlink named libexpat.so.1 which to point to libexpat.so.0.5.0 (version numbers may be different). To do this use:

# cd /usr/lib
# ln -s libexpat.so.0.5.0 libexpat.so.1

Аватар пользователя ILB

Re: новые дрова на ATI 9550

Нет, заморачиваться не буду. У меня стоят дефолтные fglrx, спасибо что откликнулись. Улыбка Не знаю будет ли полноценный OpenGL...
Хотел проверить на любимом foobillard, а тут еще одие трабл вылез :

[ilya@localhost ~]$ su
Password:
[root@localhost ilya]# mc
[root@localhost ilya]# yum install foobillard-3.0a-1.i586.rpm
Repository updates.msiu.ru-other is listed more than once in the configuration
Setting up Install Process
Setting up repositories
base 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
Parsing package install arguments
Examining foobillard-3.0a-1.i586.rpm: foobillard - 3.0a-1.i586
Marking foobillard-3.0a-1.i586.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package foobillard.i586 0:3.0a-1 set to be updated
--> Running transaction check
--> Processing Dependency: libGLcore.so.1 for package: foobillard
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package nvidia-glx.i386 0:1.0.8762-1.110asp set to be updated
--> Running transaction check
--> Processing Dependency: kernel-module-nvidia = 1.0.8762 for package: nvidia-glx
--> Processing Conflict: ati-fglrx conflicts nvidia-glx
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package ati-fglrx.i386 0:8.26.18-1.110asp set to be updated
---> Package kernel-module-nvidia-2.6.17-1.2142asp.i686 0:1.0.8762-1.110asp set to be updated
--> Running transaction check
--> Processing Dependency: /boot/vmlinuz-2.6.17-1.2142asp for package: kernel-module-nvidia-2.6.17-1.2142asp
Importing Additional filelist information for dependency resolution
--> Processing Conflict: ati-fglrx conflicts nvidia-glx
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.17-1.2142asp set to be installed
--> Running transaction check
--> Processing Conflict: ati-fglrx conflicts nvidia-glx
--> Processing Conflict: kernel conflicts lirc < 0.8.0
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package lirc.i386 0:0.8.0-0.2.110asp set to be updated
--> Running transaction check
--> Processing Conflict: ati-fglrx conflicts nvidia-glx
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Conflict: ati-fglrx conflicts nvidia-glx
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package ati-fglrx needs nvidia-glx, this is not available.
[root@localhost ilya]#

Наверное надо собирать с поддержкой ati-fglrx ? Если да, то как, из исходников ? Грустный

З.Ы. OpenGL скринсейверы работают превосходно

Аватар пользователя sergeil

Re: новые дрова на ATI 9550

Цитата:
[ilya@localhost ~]$ su
...
Repository updates.msiu.ru-other is listed more than once in the configuration

Репозитарий updates.msiu.ru-other подключен более одного раза. Я-бы сказал, это ошибка конфигурирования репозитариев yum.

Цитата:
--> Processing Conflict: ati-fglrx conflicts nvidia-glx

Если у Вас видеокарта от ATI, то зачем у Вас установлена проприетарная поддержка NVIDIA?

Цитата:
--> Processing Conflict: ati-fglrx conflicts nvidia-glx

Еще раз...

Цитата:
--> Processing Conflict: ati-fglrx conflicts nvidia-glx

Без коментариев...

Цитата:
Error: Unable to satisfy dependencies
Error: Package ati-fglrx needs nvidia-glx, this is not available.

Ну, IMHO, здесь ему совсем сорвало крышу...

Цитата:
Наверное надо собирать с поддержкой ati-fglrx ? Если да, то как, из исходников ? Грустный

Для начала удалить поддержку NVIDIA и повторить все сначала...

Цитата:
З.Ы. OpenGL скринсейверы работают превосходно

Так оно после всего этого еще и работает? :-o

Аватар пользователя ILB

Re: новые дрова на ATI 9550

Так, стоп. По порядку. Карточка стоит от ATI. Дрова стоят родные АСПовские, ничего не менял. При установке rpm (foobillard) пакета через yum он выдал ахинею, которую я привел ниже. YUM сам смотрел зависимости. Системе 2 дня. Из внешних программ установлен amule, sim ,rusxmms, cedega, rp-pppoe. Кроме rp-pppoe и cedega все ставил через yum. А ну еще mplayer через юм же и кодеки в ручную распаковывал в /usr/lib/win32 вроде, на этом же форуме вычитал...
Я так понял что yum сам модули nvidia потянул зачем-то..

З.Ы. Еще вопрос не по теме - куда карамба темы складывает ?

RSS-материал