MPlayer и H264

Аватар пользователя kostas

помогите настроить (установить кодек) mplayer в asplinux v.10
MPlayer 1.0pre7try2-3.3.3 © 2000-2005 MPlayer Team
не проигрывает видео H264

Аватар пользователя KoT

MPlayer и H264

Запустите видео через mplayer из консоли.
Вывод скопируйте сюда.

Аватар пользователя kostas

Re: MPlayer и H264

как?

Аватар пользователя kostas

Re: MPlayer и H264

пересобрал плеер: MPlayer 1.0pre8-3.3.3 (C) 2000-2006 MPlayer Team
но не устанавливается гуй- требует новый гтк, новый гтк требует новый глиб и т.д.
кроме того, видио, запущенное из консоли идет в разрешении, кода поле больше размеров экрана.
помогите с гуем!

Аватар пользователя KoT

Re: MPlayer и H264

Вам всего лишь надо установить кодеки.
Для этого как я понимаю перекомпиляция mplayer ненужна.

В обновления лежит новый mplayer
[kot@kot ~]$ rpm -q mplayer
mplayer-1.0-0.20.pre8.2.110asp

Аватар пользователя kostas

Re: MPlayer и H264

ответ юма:
# yum install mplayer
Setting up Install Process
Setting up Repo: base
repomd.xml 100% |=========================| 903 B 00:00
Setting up Repo: updates
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2124/2124
updates : ################################################## 1442/1442
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package mplayer.i386 0:1.0-0.pre7try2.100asp set to be installed
--> Running transaction check

при установки этой версии Н264 не проигрывается...

Аватар пользователя KoT

Re: MPlayer и H264

У меня просто 11, сразу не обратил внимания что у вас 10.
Этой версией (которая с 10) запустите фильм из териманала.
#mplayer name.avi
Читайте что он пишет.

Аватар пользователя kostas

Re: MPlayer и H264

$ mplayer '/home/k0sta/WWW/DVD/Ergo_Proxy_-_01_-_Awakening_-_(H264)_[AnimeReactor.ru].mkv'
MPlayer 1.0pre8-3.3.3 (C) 2000-2006 MPlayer Team
CPU: Mobile Intel(R) Celeron(R) CPU 1.50GHz (Family: 15, Model: 2, Stepping: 4)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.

Playing /home/k0sta/WWW/DVD/Ergo_Proxy_-_01_-_Awakening_-_(H264)_[AnimeReactor.ru].mkv.
[mkv] Track ID 1: video (V_MS/VFW/FOURCC), -vid 0
[mkv] Track ID 2: audio (A_AAC/MPEG2/LC), -aid 0, -alang jpn
[mkv] Track ID 3: audio (A_AAC/MPEG4/LC/SBR), -aid 1, -alang rus
[mkv] Will play video track 1
[mkv] Will play audio track 3
Matroska file format detected.
VIDEO: [H264] 1280x720 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
==========================================================================
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
alsa-init: using device default
alsa: 44100 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 1280x720 => 1280x720 Planar YV12
aspect: Warning: no suitable new res found!
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
A: 1.7 V: 1.6 A-V: 0.099 ct: 0.018 41/ 41 63% 35% 6.3% 14 0
===== PAUSE =====

Аватар пользователя redd

MPlayer и H264

kostas писал(а):
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 1280x720 => 1280x720 Planar YV12
aspect: Warning: no suitable new res found!
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
A: 1.7 V: 1.6 A-V: 0.099 ct: 0.018 41/ 41 63% 35% 6.3% 14 0

Похоже проблемы с шрифтами - покрайней мере он так пишет. Он требует файл subfont.ttf в директории mplayer-a. Я бы попробовал удалить mplayer и установить заново используя yum.

RSS-материал