Atheros AR5005G в ASP 11.2

Аватар пользователя wildsin

народ, помогите... крыша уже едет... имеется:
1. ASP 11.2
2. kernel-2.6.20-1.2320.1.112asp
3. соответствующий devel
4. полные сконфигурированные исходники этого же ядра

железо:

Цитата:
# lspci
0a:03.0 Ethernet controller: Atheros Communications, Inc. AR5005G 802.11abg NIC (rev 01)
# lspci -n
0a:03.0 0200: 168c:001a (rev 01)
#lspci -nv
0a:03.0 0200: 168c:001a (rev 01)
Subsystem: 1468:0418
Flags: medium devsel, IRQ 18
Memory at d0000000 (32-bit, non-prefetchable) [=64K]
Capabilities: [44] Power Management version 2

драйвера:

Цитата:
# rpm -qa | grep madw
kmod-madwifi-0.9.3.3-1.2.6.20_1.2320.1.112asp
madwifi-0.9.3.3-1

дрова собраны на этой машине с этим ядром...модуль о себе пишет, что

Цитата:
#modinfo ath_pci
filename: /lib/modules/2.6.20-1.2320.1.112asp/extra/madwifi/ath_pci.ko
license: Dual BSD/GPL
version: 0.9.3.3
description: Support for Atheros 802.11 wireless LAN cards.
author: Errno Consulting, Sam Leffler
.............................
alias: pci:v0000168Cd0000001Asv*sd*bc*sc*i*
.............................
depends: ath_hal,wlan
vermagic: 2.6.20-1.2320.1.112asp mod_unload 686 4KSTACKS
.............................

после модпробы этого модуля в dmesg появляется запись:

Цитата:
# dmesg
ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
wlan: 0.8.4.2 (0.9.3.3)
ath_pci: 0.9.4.5 (0.9.3.3)
ACPI: PCI Interrupt 0000:0a:03.0[A] -> GSI 18 (level, low) -> IRQ 18
wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
ACPI: PCI interrupt for device 0000:0a:03.0 disabled

какого лешего ему не хватает? железо таки 168C:001A и у модуля в алиасах присутствует оно же...
чего делать, кто сталкивался?

RSS-материал