IcaCitrix клиент для ASPlinux12

Аватар пользователя arayakao

Установил IcaCitrix и все пакеты которые он просил, но при запуске из командной строки появляется ошибка
[andrey@crocus ~]$ /usr/lib/ICAClient/wfcmgr -icaroot /usr/lib/ICAClient
/usr/lib/ICAClient/wfcmgr.bin: error while loading shared libraries: libXm.so.3: cannot open shared object file: No such file or directory

Что делать ? Как это исправить ?

Аватар пользователя im_lamer

Re: IcaCitrix клиент для ASPlinux12

Hi!
libXm.so.3 - библиотека из пакета OpenMotiff.
Для начала проверь версию пакета OpenMotiff. должно быть openmotif-2.2.*.rpm, с более новыми ICA не заработает. например, у меня - openmotif-2.2.3-2mdk.i586.rpm.

Потом, проверь есть ли у тя в /usr/lib/ эта библиотека. у мну было
----------------------
[root@lamer ICAClient]# locate libXm.so.3
/usr/X11R6/lib/libXm.so.3
-------------------------
т.е. она лежала не там где нада (точнее там где клиент цитрикса ее не видел).
просто cделай линк на нее в /ust/lib/
---------
[root@lamer ICAClient]# ln -s /usr/X11R6/lib/libXm.so.3 /usr/lib/libXm.so.3
----------------------------------
После этого у мну все заработало.

Аватар пользователя arayakao

Re: IcaCitrix клиент для ASPlinux12

А как удалить новую версию openmotif ? чтоб потом можно установить версию постарше ? У мну не получается

RSS-материал