Не работает сеть в ASPLinux 14

Аватар пользователя AngelFX

Не работет сеть в ASPLinux 14, форумы читал, то что советовали не помогает.
Я конечно понимаю, что меня сейчас будут пинать, отправлять погуглить, воспользоваться поиском и т.п. Я этим всем пользовался, но ничего не нашел Может плохо искал.
Мои дейтвия:
При установке ASPLinux 14 по запросу вбиваю IP-адрес компа, маску, шлюз, первичный DNS, вторичный DNS. Устанавливается, запускаю гном, захожу под рутом и сеть не работает. Пинги не проходят. Сайты не открываются. Проверяю натройки в system-config-network, все верно. Лезу читаю форумы. Пишут надо удалить NetworkManager командой yum remove NetworkManager. Удалил. Сеть не работает.
Пробовал ifconfig eth0 192.168.1.4 netmask 255.255.255.0 up. После этой команды сеть должна заработать, покрайней мере пинги на соседние машины, но не рабаотает. Переустановил ASPLinux 14. В службах отключил NetworkManager, включил Network. Настроил все ручками в конфигурационных файлах. Все равно не работает.
Создавал файлы как в unix:
/etc/hostname.eth0 - имя машины
/etc/hosts - сопоставление имен машин с ip-адресами (в моем случае один ip и одно имя)
/etc/resolv.conf - DNS сервера
/etc/defaultrouter - шлюз
Должно было работать. По крайней мере в Solaris 10 это работало, только надо было еще строчку в /etc/nsswitch дописать, чтоб в нет ходил. Без неё только по локалке.
Поробовал еще обновить NetworkManager вручную установив пакеты, обновилось успешно без косяков, но сеть не заработала.
Сейчас еще раз переустановил, в службах отключил NetworkManager, включил Network. И через system-config-network настроил.
Сетевая карточка CNET PRO200 PCI Fast Ethernet или в народе DAVICOM 9102AF
Пожалуйста, помогите разобраться в чем проблема.

Аватар пользователя AngelFX

Re: Не работает сеть в ASPLinux 14

Вот что выдаёт ifconfig:
[root@ASPLinux-PC ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:08:A1:90:D9:AD
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::208:a1ff:fe90:d9ad/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:748 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1985 (1.9 KiB) TX bytes:34493 (33.6 KiB)
Interrupt:16 Base address:0xa000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2826 errors:0 dropped:0 overruns:0 frame:0
TX packets:2826 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
********
netstat -nr:
[root@ASPLinux-PC ~]# netstat -nr
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
********
Пинг на роутер:
[root@ASPLinux-PC ~]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.4 icmp_seq=2 Destination Host Unreachable
From 192.168.1.4 icmp_seq=3 Destination Host Unreachable
From 192.168.1.4 icmp_seq=4 Destination Host Unreachable
From 192.168.1.4 icmp_seq=6 Destination Host Unreachable
From 192.168.1.4 icmp_seq=7 Destination Host Unreachable
From 192.168.1.4 icmp_seq=8 Destination Host Unreachable
*******
Пинг на соседний комп:
[root@ASPLinux-PC ~]# ping 192.168.1.2
PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.
From 192.168.1.4 icmp_seq=2 Destination Host Unreachable
From 192.168.1.4 icmp_seq=3 Destination Host Unreachable
From 192.168.1.4 icmp_seq=4 Destination Host Unreachable
From 192.168.1.4 icmp_seq=6 Destination Host Unreachable
From 192.168.1.4 icmp_seq=7 Destination Host Unreachable
From 192.168.1.4 icmp_seq=8 Destination Host Unreachable
*******
Файл /etc/sysconfig/network-scripts/ifcfg-eth0:
# Davicom Semiconductor, Inc. 21x4x DEC-Tulip compatible 10/100 Ethernet
DEVICE=eth0
BOOTPROTO=none
BROADCAST=192.168.1.255
HWADDR=00:08:a1:90:d9:ad
IPADDR=192.168.1.4
IPV6INIT=yes
IPV6_AUTOCONF=yes
NETMASK=255.255.255.0
NETWORK=192.168.1.0
ONBOOT=yes
DNS1=195.46.116.1
DNS2=195.46.96.1
NM_CONTROLLED=no
GATEWAY=192.168.1.1
TYPE=Ethernet
USERCTL=no
PEERDNS=yes

У меня стаж работы с unix подобными системами две недели, так что сильно не ругайте. ;)
Меня смущает первая строчка в файле /etc/sysconfig/network-scripts/ifcfg-eth0, у меня сетевая карта DAVICOM 9102AF.....

Аватар пользователя Телепат_

Re: Не работает сеть в ASPLinux 14

AngelFX писал(а):
Вот что выдаёт ifconfig:
[root@ASPLinux-PC ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:08:A1:90:D9:AD
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
RX bytes:1985 (1.9 KiB) TX bytes:34493 (33.6 KiB)
Interrupt:16 Base address:0xa000

Таки ведь работает!

Цитата:
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

Ну да, вроде правильно
********

Цитата:
Пинг на роутер:
[root@ASPLinux-PC ~]# ping 192.168.1.1

Файл /etc/sysconfig/network-scripts/ifcfg-eth0:
# Davicom Semiconductor, Inc. 21x4x DEC-Tulip compatible 10/100 Ethernet
DEVICE=eth0
BOOTPROTO=none
BROADCAST=192.168.1.255
HWADDR=00:08:a1:90:d9:ad
IPADDR=192.168.1.4

вроде правильно.

Цитата:
У меня стаж работы с unix подобными системами две недели, так что сильно не ругайте. ;)

Да нет, все абсолютно правильно делается...

Думаю, что-то в модуле ядра. Ндо попробовть либо обновить ядро, ибо скомпилить модуль под существующее.
Посмотрите также что плохого есть в логах???

Аватар пользователя AngelFX

Re: Не работает сеть в ASPLinux 14

Эээээ... Я все-таки новичок. Где эти логи лежат? Улыбка)

Аватар пользователя AngelFX

Re: Не работает сеть в ASPLinux 14

Solaris 10 настроил, ходит в сеть и в интернет без проблем. Поставил еще ASPLinux 12, до этого он стоял и работал с сетью нормально, карточку эту сразу определял и после установки сразу рабочая сеть и интернет были. А сейчас и ASP12 не работает с сетью.. Сейчас на компе стоит Solaris 10, ASP14 и ASP12. Я надеюсь между ними конфликтов быть не может? Стоят в разных рахделах на одном винте..

Аватар пользователя Телпат_

Re: Не работает сеть в ASPLinux 14

AngelFX писал(а):
Эээээ... Я все-таки новичок. Где эти логи лежат? Улыбка)

/var/log

Запустите system-config-network и посмотрите, тот ли "драйвер" ассоциирован с карточкой.

(лучше конечно через lspci, dmesg, lsmod и m odprobe )

Аватар пользователя AngelFX

Re: Не работает сеть в ASPLinux 14

Спасибо большое за советы!
Дело в другом окзалось. Отходила сетевая карточка (плохой контакт был, но главное, что был). При этом в Solaris 10 работала, но медленно. Я думал из-за старого драйвера для Solaris 10. А в ASP 12 и 14, корректно опрделелял сетевуху, но при этом сеть не работала... Я в шоке... Забавно, конечно, получилось. Случайно обнаружил, полез от безнадежности на железо взглянуть и вижу карточка с перекосом стоит, у неё крепление металлическое, которое к корпусу прикручивается, кривое было, вот и вытягивала карточку как пружина... Я одного не понимаю, как Solaris 10 работал??? Драйвер на него ручками ставил.
Можно считать тема закрыта. Еще раз спасибо большое!

Аватар пользователя Телпат_

Re: Не работает сеть в ASPLinux 14

AngelFX писал(а):
Спасибо большое за советы!
Дело в другом окзалось. Отходила сетевая карточка (плохой контакт был, но главное, что был). П
Можно считать тема закрыта. Еще раз спасибо большое!

Эту проблемму увидели бы в dmesg...

Аватар пользователя AngelFX

Re: Не работает сеть в ASPLinux 14

Возможно... Но в Solaris 10 работала все-таки, хоть и медленно, но работала.. Я даже об dmesg и не подумал... Спасибо!

RSS-материал