Проблема монтирования в GNOME после обновления

Автор: repairman Дата: 01.09.2009 12:56 День добрый.

Получил последние обновления для Cobalt... теперь не монтируется ни один диск в NAUTILUS из учетки юзера, ни автоматом ни вручную... диски все вижу, любые попытки смонтировать/открыть - тихо игнорируются (2 машины - эффект точно одинаковый) Из под рута все ок.... работать в X'ах под рутом очень не хочется...

Как вернуть взад ?

Заранее спасибо.

yum произвел следующее:

Sep 1 12:32:06 repairman yum: Updated: glib2-2.18.4-2.0.140asp.i386
Sep 1 12:32:10 repairman yum: Updated: hal-libs-0.5.12-14.20081027git.0.140asp.1.i386
Sep 1 12:32:15 repairman yum: Updated: bluez-libs-4.30-2.0.140asp.1.i386
Sep 1 12:32:20 repairman yum: Installed: libasyncns-0.7-2.0.140asp.i386
Sep 1 12:32:54 repairman yum: Updated: pulseaudio-libs-0.9.15-16.0.140asp.i386
Sep 1 12:33:02 repairman yum: Updated: alsa-lib-1.0.20-1.0.140asp.i386
Sep 1 12:33:06 repairman yum: Updated: libtool-ltdl-2.2.6-11.0.140asp.1.i386
Sep 1 12:33:19 repairman yum: Installed: libgphoto2-2.4.4-1.0.140asp.i386
Sep 1 12:33:23 repairman yum: Updated: libsoup-2.24.3-1.0.140asp.i386
Sep 1 12:34:01 repairman yum: Updated: gvfs-1.0.3-10.0.140asp.i386
Sep 1 12:34:09 repairman yum: Updated: ConsoleKit-libs-0.3.0-8.0.140asp.noarch
Sep 1 12:34:18 repairman yum: Updated: ConsoleKit-0.3.0-8.0.140asp.noarch
Sep 1 12:34:57 repairman yum: Updated: openldap-2.4.15-5.0.140asp.i386
Sep 1 12:35:02 repairman yum: Updated: libvolume_id-141-6.0.140asp.i386
Sep 1 12:35:17 repairman yum: Updated: udev-141-6.0.140asp.i386
Sep 1 12:35:24 repairman yum: Updated: cryptsetup-luks-1.0.6-7.0.140asp.i386
Sep 1 12:35:37 repairman yum: Installed: udev-extras-20090125-0.3.20090129git.0.140asp.i386
Sep 1 12:35:47 repairman yum: Installed: pulseaudio-0.9.15-16.0.140asp.i386
Sep 1 12:35:50 repairman yum: Installed: gvfs-obexftp-1.0.3-10.0.140asp.i386
Sep 1 12:36:52 repairman yum: Updated: bluez-gnome-1.8-16.0.140asp.i386
Sep 1 12:37:39 repairman yum: Updated: 5:guile-1.8.5-1.0.140asp.1.i386
Sep 1 12:37:52 repairman yum: Updated: graphviz-2.16.1-0.6.0.140asp.i386
Sep 1 12:38:17 repairman yum: Updated: pulseaudio-libs-glib2-0.9.15-16.0.140asp.i386
Sep 1 12:38:25 repairman yum: Updated: pulseaudio-utils-0.9.15-16.0.140asp.i386
Sep 1 12:38:31 repairman yum: Updated: pulseaudio-libs-zeroconf-0.9.15-16.0.140asp.i386
Sep 1 12:38:42 repairman yum: Installed: gettext-devel-0.17-4.0.140asp.i386
Sep 1 12:39:04 repairman yum: Updated: pulseaudio-module-x11-0.9.15-16.0.140asp.i386
Sep 1 12:39:12 repairman yum: Updated: bluez-4.30-2.0.140asp.1.i386
Sep 1 12:39:17 repairman yum: Updated: pulseaudio-module-gconf-0.9.15-16.0.140asp.i386
Sep 1 12:39:44 repairman yum: Updated: hal-0.5.12-14.20081027git.0.140asp.1.i386
Sep 1 12:39:52 repairman yum: Updated: openldap-clients-2.4.15-5.0.140asp.i386
Sep 1 12:39:54 repairman yum: Updated: ConsoleKit-x11-0.3.0-8.0.140asp.noarch
Sep 1 12:39:57 repairman yum: Updated: gvfs-fuse-1.0.3-10.0.140asp.i386
Sep 1 12:40:01 repairman yum: Updated: bluez-alsa-4.30-2.0.140asp.1.i386
Sep 1 12:40:05 repairman yum: Updated: alsa-utils-1.0.20-3.0.140asp.i386
Sep 1 12:40:12 repairman yum: Updated: bluez-cups-4.30-2.0.140asp.1.i386
Sep 1 12:40:15 repairman yum: Updated: icedax-1.1.9-6.0.140asp.i386
Sep 1 12:40:41 repairman yum: Updated: wodim-1.1.9-6.0.140asp.i386
Sep 1 12:40:47 repairman yum: Updated: genisoimage-1.1.9-6.0.140asp.i386
Sep 1 12:40:53 repairman yum: Installed: libexif-devel-0.6.16-1.0.140asp.i386
Sep 1 12:40:58 repairman yum: Installed: libusb-devel-0.1.12-15.0.140asp.i386
Sep 1 12:41:05 repairman yum: Installed: libgphoto2-devel-2.4.4-1.0.140asp.i386
Sep 1 12:41:10 repairman yum: Updated: pulseaudio-esound-compat-0.9.15-16.0.140asp.i386
Sep 1 12:41:24 repairman yum: Updated: intltool-0.40.5-1.0.140asp.i386
Sep 1 12:41:39 repairman yum: Erased: gphoto2
Sep 1 12:43:50 repairman yum: Erased: pulseaudio-core-libs
Re: Проблема монтирования в GNOME после обновления 01.09.2009 15:25repairman Ок, перефразирую вопрос:

Что отвечает за монтирование дисков в gnome ?
Какие опции в каких файлах нужно проверить на разрешение/запрет монтирования из под юзера ?

p.s. в логах не вижу ничего подозрительного...
Re: Проблема монтирования в GNOME после обновления 01.09.2009 17:16peter_ir Есть же настройки - на панели System->Preferences и там найти Removable,
но сначала лучше настроить /etc/fstab, там и могут быть опции, разрешающие
монтирование user'у (users/nousers).
Re: Проблема монтирования в GNOME после обновления 01.09.2009 18:18BigAndy
Цитата:
Из под рута все ок.... работать в X'ах под рутом очень не хочется

либо у вас упал демон hal/udev,либо слетели правила оттуда.
Пропишите в fstab в пятой колонке user и счастье вам улыбнется.
Re: Проблема монтирования в GNOME после обновления 01.09.2009 18:21BigAndy repairman Пишет:
-------------------------------------------------------
> Ок, перефразирую вопрос:
>
> Что отвечает за монтирование дисков в gnome ?
> Какие опции в каких файлах нужно проверить на
> разрешение/запрет монтирования из под юзера ?
>
> p.s. в логах не вижу ничего подозрительного...
если вы про gnome- то идиотский gvfs.
Но обычно за правила монтирования сменных носителй отвечают udev/haldaemon.
Они же и раздают права на смонтированные устройства
Re: Проблема монтирования в GNOME после обновления 02.09.2009 12:23ZZTop Видимо у меня такая же проблема.
Проявляется в том, что под юзером не монтируются флешки и другие hdd не прописанные напрямую в fstab. При этом их видно через ярлычек на рабочем столе "компьютер". При попытке смонтировать - "Не удалось подключить том", а подробнее IsCallerPriveleged() failed

Если жестко прописать в fstab - то диск появляется.
При этом из под рута все работает.
Понятное дело, что слетели права юзеров на монтирование файловых систем. Но вот какой именно конфиг слетел?
Re: Проблема монтирования в GNOME после обновления 02.09.2009 13:29BigAndy Ну так я вам прямо указал выше несколько возможных причин.
исключайте их последовательно.
Re: Проблема монтирования в GNOME после обновления 03.09.2009 09:39repairman Да, вот еще какая особенность:

Если загружаться в level 5 - все ок, все диски есть, если в level 3 с последующим startx (чем я всегда пользовался и никаких проблем никогда не имел) - получаем описанный глюк...

Никто еще не нашел причину ?
Re: Проблема монтирования в GNOME после обновления 03.09.2009 10:02BigAndy А скто кроме вас ее найдет?
Для начала смотрим.
chkconfig и смотрим, что в runlevel 3 не работает, то , что стартует в runlevel 5 и опять же проверяем [forum.asplinux.ru]
Re: Проблема монтирования в GNOME после обновления 03.09.2009 10:07msv2 BigAndy Пишет:
-------------------------------------------------------
> А скто кроме вас ее найдет?
> Для начала смотрим.
> chkconfig и смотрим, что в runlevel 3 не работает,
> то , что стартует в runlevel 5 и опять же
> проверяем
> [forum.asplinux.ru]#
> msg-229403


+100
Опередили!!!
Re: Проблема монтирования в GNOME после обновления 03.09.2009 10:17repairman chkconfig разница только в gpm, IMHO консольный драйвер мыши тут не при чем...

Добавление в /etc/PolicyKit/PolicyKit.conf явного разрешения для юзера решает проблему.

    <match action="org.freedesktop.hal.storage.mount-fixed">
        <match user="repairman">
            <return result="yes"/>
        </match>
    </match>


PolicyKit не обновлялся, значит что-то другое...
Странно все это... из какой rpm сценарий грохает права юзера ?
Re: Проблема монтирования в GNOME после обновления 03.09.2009 10:42BigAndy O_o
PolicyKit сценарии работают по-разному в mode 5 и mode 3???
Re: Проблема монтирования в GNOME после обновления 03.09.2009 10:47repairman В файле политики по умолчанию (не изменялся при апдейте):
/usr/share/PolicyKit/policy/org.freedesktop.hal.storage.policy

Право на монтирование fixed дисков даны auth_admin_keep_always... меняем на yes - право получают все...

И все же осталось непонятно:
1. Раз файлы политики не менялись, то есть что-то перекрывающее политику. Что и где ?
2. Какой-то rpm пакет принес изменения, которых быть не должно. Какой ?

Хотелось бы, чтобы сборщики обратили на это внимание.

p.s. поспешил, без явного разрешения в PolicyKit.conf, через политику по умолчанию - проблема НЕ решается...
Re: Проблема монтирования в GNOME после обновления 03.09.2009 12:52ZZTop Все оказаось просто как апельсин. yum проапдейтил не все пакеты которые имелись для обновления. Просто некоторые не сумел разрешить по зависимостям и обломился. Почему то не сумел унинсталить старые версии пакетов. Уж почему он этого не сумел сделать, и каким образом всетаки обновил некоторые пакеты - для меня загадка. Ну да и бох с ней. Я руками, тем же юмом сначала удалил несколько старых пакетов, после чего все обновления встали как родные. И все заработало ;-)
Re: Проблема монтирования в GNOME после обновления 03.09.2009 15:44repairman Какие пакеты, если не секрет ?
Re: Проблема монтирования в GNOME после обновления 03.09.2009 17:50msv2 Вот сейчас обновился, все замечательно работает.
Re: Проблема монтирования в GNOME после обновления 03.09.2009 17:56repairman msv2 Пишет:
-------------------------------------------------------
> Вот сейчас обновился, все замечательно работает.


В level 5 ?
Re: Проблема монтирования в GNOME после обновления 04.09.2009 08:51ZZTop repairman Пишет:
-------------------------------------------------------
> Какие пакеты, если не секрет ?


Некоторые некашерные кодеки из audiocius и пару пакетов из bluez. Какие именно уже не помню. Вроде бы bluez-tools или bluez-libs... не помню точно Грустный
RSS-материал