Мониторинг температуры процессора

Автор: nsk Дата: 12.04.2005 12:59 Подскажите, пожалуйста, как в линуксе (оболочка КДЕ) посмотреть температуру процессора? И если это возможно, то как сделать, чтобы она постоянно отображалась в трее? Есть ли такого рода программа в дистрибутиве ASPLinux 9.2 Express?
Re: Мониторинг температуры процессора 12.04.2005 15:28Vinnie Программа для KDE называется ksensors, это фронтэнд для lm-sensors. Умеет показывать температуру процессора, скорость работы вентилятора, напряжения питания на материнке и т.д., отображает все это как в kicker-е, так и в отдельной панели. Но gkrellm, написанный для GTK+ гораздо круче выглядит.
Re: Мониторинг температуры процессора 13.04.2005 01:09Gorch Показывать - нафик надо... есть прога, чтобы изменяла частоту вращения кулера в зависимости от нагрева процессора (аналог Speedfan в винде)?
Re: Мониторинг температуры процессора 13.04.2005 14:08Bircoph Крутите lm_sensors и пишите скрипт изменения частоты кулера (используя средства контроля QFAN lm_sensors)
Re: Мониторинг температуры процессора 14.04.2005 18:13perest слушайте, ребят, а вот если я скачаю ksensors, к ней надо ещё lm-sensors скачивать? или она как стандартная уже входит? и просто установить ksensors останется и всё?
Re: Мониторинг температуры процессора 14.04.2005 19:17CyberPunk >слушайте, ребят, а вот если я скачаю ksensors, к ней надо ещё lm-sensors скачивать?

Готовый lm_sensors со всеми потрохами входит в комплект поставки с 9-й версии ASP, если не раньше, для конфигурирования нужно только запустить скрипт (вот этот скрипт мне пришлось немного править руками - пути не туда вели). Единственная проблема - у меня этот lm_sensors почему-то иногда начинает читать обороты кулера не сразу, а только через несколько минут после запуска.
Re: Мониторинг температуры процессора 14.04.2005 19:50perest а что за скрипт?
слушай, а если я качну gkrellm, то там не надо будет со скриптами возиться? или тоже придётся делать чёто? а то я не рублю в этом... Грустный
Re: Мониторинг температуры процессора 14.04.2005 20:11Igor_FF как проверить, включен ли модуль i2с в ядро? ... говорят без него lm_sensors не работает
Re: Мониторинг температуры процессора 16.04.2005 22:22CyberPunk >слушай, а если я качну gkrellm, то там не надо будет со скриптами возиться? или тоже придётся делать чёто?

Все равно придется мскрипт инициализации запускать. Этот скрипт выполняет настройки, без которых lm_sensors просто не знает, как считывать температуру. И вообще этот gkrellm сильно на любителя, датчиков в нем куда как побольше, но на экране болтается, как г... в проруби. А KSensors просто сидит в трее и показывает, что скажут.
Re: Мониторинг температуры процессора 22.04.2005 13:14nsk Я вчера нашел у себя и установил GKrellM. Неплохо, только он пока не нашел у меня никаких сенсоров. Вижу только загрузку процессора, памяти и так, по мелочам. Вот ещё бы температуру и вообще здорово. Это как-то связано с упоминавшимся скриптом для lm_sensors? Если да, то что это за скрипт?
Re: Мониторинг температуры процессора 22.04.2005 19:19Bircoph Запустите от рута sensors-detect, __внимательно__ ответьте на заданные вопросы (иначе можете глюкавое железо грохнуть), выполните указанные действия (нужно будет добавить сгенерированный скрипт в скрипты инициализации для автоматической подгрузки нужных модулей) и радуйтесь жизни ;-)).
Re: Мониторинг температуры процессора 27.04.2005 07:14nsk Что-то нет у меня команды sensors-detect... Что-то наверное не установлено?
Re: Мониторинг температуры процессора 27.04.2005 10:03plaq 2nsk:
/usr/sbin/sensors-detect


попробовал я эти сенсоры, для xfce есть спец. плагин, который на панель выводит эти значения,
но в настройках этих парамеров туева хуча, да ещё не понятно в каких попугаях они измеряются
где можно посмотреть что чему соответствует?
Re: Мониторинг температуры процессора 13.12.2005 11:31data2or Помогите настроить lm-sensors
ядро 2.6.9smp, пересобранное из kernel-2.6.9-1.667asp.src.rpm
и
lm_sensors-2.8.7-2.i386.rpm

запускаю от root

sensors-detect
---------------------------------------------------------------------
This program will help you determine which I2C/SMBus modules you need to
load to use lm_sensors most effectively. You need to have i2c and
lm_sensors installed before running this program.
Also, you need to be `root', or at least have access to the /dev/i2c-*
files, for most things.
If you have patched your kernel and have some drivers built in, you can
safely answer NO if asked to load some modules. In this case, things may
seem a bit confusing, but they will still work.

It is generally safe and recommended to accept the default answers to all
questions, unless you know what you're doing.

We can start with probing for (PCI) I2C or SMBus adapters.
You do not need any special privileges for this.
Do you want to probe now? (YES/no): YES
Probing for PCI bus adapters...
Use driver `i2c-i801' for device 00:1f.3: Intel 82801EB ICH5
Probe succesfully concluded.

We will now try to load each adapter module in turn.
Module `i2c-i801' already loaded.
If you have undetectable or unsupported adapters, you can have them
scanned by manually loading the modules before running this script.

To continue, we need module `i2c-dev' to be loaded.
If it is built-in into your kernel, you can safely skip this.
i2c-dev is not loaded. Do you want to load it now? (YES/no): YES
Module loaded succesfully.

We are now going to do the adapter probings. Some adapters may hang halfway
through; we can't really help that. Also, some chips will be double detected;
we choose the one with the highest confidence value in that case.
If you found that the adapter hung after probing a certain address, you can
specify that address to remain unprobed. That often
includes address 0x69 (clock chip).

Next adapter: SMBus I801 adapter at c800 (Algorithm unavailable)
Do you want to scan it? (YES/no/selectively): YES
Client found at address 0x08
Client found at address 0x2e
Probing for `Myson MTP008'... Failed!
Probing for `National Semiconductor LM78'... Failed!
Probing for `National Semiconductor LM78-J'... Failed!
Probing for `National Semiconductor LM79'... Failed!
Probing for `National Semiconductor LM80'... Failed!
Probing for `National Semiconductor LM85'... Failed!
Probing for `Analog Devices ADM1027, ADT7460 or ADT7463'... Failed!
Probing for `SMSC EMC6D100 or EMC6D101'... Success!
(confidence 7, driver `lm85')
Probing for `Analog Devices ADT7467'... Failed!
Probing for `National Semiconductor LM87'... Failed!
Probing for `Winbond W83781D'... Failed!
Probing for `Winbond W83782D'... Failed!
Probing for `Winbond W83791D'... Failed!
Probing for `Winbond W83627HF'... Failed!
Probing for `Asus AS99127F (rev.1)'... Failed!
Probing for `Asus AS99127F (rev.2)'... Failed!
Probing for `Asus ASB100 Bach'... Failed!
Probing for `Winbond W83L785TS-S'... Failed!
Probing for `Analog Devices ADM9240'... Failed!
Probing for `Dallas Semiconductor DS1780'... Failed!
Probing for `National Semiconductor LM81'... Failed!
Probing for `Analog Devices ADM1026'... Failed!
Probing for `Analog Devices ADM1025'... Failed!
Probing for `Analog Devices ADM1024'... Failed!
Probing for `Analog Devices ADM1029'... Failed!
Probing for `Analog Devices ADM1030'... Failed!
Probing for `Analog Devices ADM1031'... Failed!
Probing for `Analog Devices ADM1022'... Failed!
Probing for `Texas Instruments THMC50'... Failed!
Probing for `Analog Devices ADM1028'... Failed!
Probing for `ITE IT8705F / IT8712F / SiS 950'... Failed!
Client found at address 0x30
Client found at address 0x32
Client found at address 0x44
Probing for `Maxim MAX6633/MAX6634/MAX6635'... Failed!
Client found at address 0x50
Probing for `SPD EEPROM'... Success!
(confidence 8, driver `eeprom')
Probing for `DDC monitor'... Failed!
Probing for `Maxim MAX6900'... Failed!
Client found at address 0x52
Probing for `SPD EEPROM'... Success!
(confidence 8, driver `eeprom')
Client found at address 0x61
Probing for `SMBus 2.0 ARP-Capable Device'... Success!
(confidence 1, driver `smbus-arp')
Client found at address 0x69

Next adapter: bt878 #0 [sw] (Algorithm unavailable)
Do you want to scan it? (YES/no/selectively): YES
Client found at address 0x50
Probing for `SPD EEPROM'... Success!
(confidence 1, driver `eeprom')
Probing for `DDC monitor'... Failed!
Probing for `Maxim MAX6900'... Failed!
Client at address 0x61 can not be probed - unload all client drivers first!

Some chips are also accessible through the ISA bus. ISA probes are
typically a bit more dangerous, as we have to write to I/O ports to do
this. This is usually safe though.

Do you want to scan the ISA bus? (YES/no): YES
Probing for `National Semiconductor LM78'
Trying address 0x0290... Failed!
Probing for `National Semiconductor LM78-J'
Trying address 0x0290... Failed!
Probing for `National Semiconductor LM79'
Trying address 0x0290... Failed!
Probing for `Winbond W83781D'
Trying address 0x0290... Failed!
Probing for `Winbond W83782D'
Trying address 0x0290... Failed!
Probing for `Winbond W83627HF'
Trying address 0x0290... Failed!
Probing for `Winbond W83697HF'
Trying address 0x0290... Failed!
Probing for `Silicon Integrated Systems SIS5595'
Trying general detect... Failed!
Probing for `VIA Technologies VT82C686 Integrated Sensors'
Trying general detect... Failed!
Probing for `VIA Technologies VT8231 Integrated Sensors'
Trying general detect... Failed!
Probing for `ITE IT8705F / IT8712F / SiS 950'
Trying address 0x0290... Failed!
Probing for `IPMI BMC KCS'
Trying address 0x0ca0... Failed!
Probing for `IPMI BMC SMIC'
Trying address 0x0ca8... Failed!

Some Super I/O chips may also contain sensors. Super I/O probes are
typically a bit more dangerous, as we have to write to I/O ports to do
this. This is usually safe though.

Do you want to scan for Super I/O sensors? (YES/no): YES
Probing for `ITE 8702F Super IO Sensors'
Failed! (0xf0d1)
Probing for `ITE 8705F Super IO Sensors'
Failed! (0xf0d1)
Probing for `ITE 8712F Super IO Sensors'
Failed! (0xf0d1)
Probing for `Nat. Semi. PC87351 Super IO Fan Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87360 Super IO Fan Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87363 Super IO Fan Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87364 Super IO Fan Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87365 Super IO Fan Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87365 Super IO Voltage Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87365 Super IO Thermal Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87366 Super IO Fan Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87366 Super IO Voltage Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87366 Super IO Thermal Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC87372 Super IO Fan Sensors'
Success... found at address 0x06e0
Probing for `Nat. Semi. PC87373 Super IO Fan Sensors'
Failed! (0xf0)
Probing for `Nat. Semi. PC8741x Super IO'
Failed! (0xf0)
Probing for `SMSC 47B27x Super IO Fan Sensors'
Failed! (0xf0)
Probing for `SMSC 47M10x/13x Super IO Fan Sensors'
Failed! (0xf0)
Probing for `SMSC 47M14x Super IO Fan Sensors'
Failed! (0xf0)
Probing for `SMSC 47M15x/192 Super IO Fan Sensors'
Failed! (0xf0)
Probing for `SMSC 47S42x Super IO Fan Sensors'
Failed! (0xf0)
Probing for `SMSC 47S45x Super IO Fan Sensors'
Failed! (0xf0)
Probing for `SMSC 47M172 Super IO'
Failed! (0xf0)
Probing for `VT1211 Super IO Sensors'
Failed! (0xf0)
Probing for `Winbond W83627HF Super IO Sensors'
Failed! (0xf0)
Probing for `Winbond W83627THF Super IO Sensors'
Failed! (0xf0)
Probing for `Winbond W83637HF Super IO Sensors'
Failed! (0xf0)
Probing for `Winbond W83697HF Super IO Sensors'
Failed! (0xf0)
Probing for `Winbond W83697SF/UF Super IO PWM'
Failed! (0xf0)
Probing for `Winbond W83L517D Super IO'
Failed! (0xf0)

Do you want to scan for secondary Super I/O sensors? (YES/no): YES
Probing for `ITE 8702F Super IO Sensors'
Failed! (skipping family)
Probing for `Nat. Semi. PC87351 Super IO Fan Sensors'
Failed! (skipping family)
Probing for `SMSC 47B27x Super IO Fan Sensors'
Failed! (skipping family)
Probing for `VT1211 Super IO Sensors'
Failed! (skipping family)

Now follows a summary of the probes I have just done.
Just press ENTER to continue:

Driver `lm85' (should be inserted):
Detects correctly:
* Bus `SMBus I801 adapter at c800' (Algorithm unavailable)
Busdriver `i2c-i801', I2C address 0x2e
Chip `SMSC EMC6D100 or EMC6D101' (confidence: 7)

Driver `eeprom' (should be inserted):
Detects correctly:
* Bus `SMBus I801 adapter at c800' (Algorithm unavailable)
Busdriver `i2c-i801', I2C address 0x50
Chip `SPD EEPROM' (confidence: Поражён
* Bus `SMBus I801 adapter at c800' (Algorithm unavailable)
Busdriver `i2c-i801', I2C address 0x52
Chip `SPD EEPROM' (confidence: Поражён
* Bus `bt878 #0 [sw]' (Algorithm unavailable)
Busdriver `UNKNOWN', I2C address 0x50
Chip `SPD EEPROM' (confidence: 1)

Driver `smbus-arp' (should be inserted):
Detects correctly:
* Bus `SMBus I801 adapter at c800' (Algorithm unavailable)
Busdriver `i2c-i801', I2C address 0x61
Chip `SMBus 2.0 ARP-Capable Device' (confidence: 1)

Driver `to-be-written' (should be inserted):
Detects correctly:
* ISA bus address 0x06e0 (Busdriver `i2c-isa')
Chip `Nat. Semi. PC87372 Super IO Fan Sensors' (confidence: 9)


I will now generate the commands needed to load the I2C modules.
Sometimes, a chip is available both through the ISA bus and an I2C bus.
ISA bus access is faster, but you need to load an additional driver module
for it. If you have the choice, do you want to use the ISA bus or the
I2C/SMBus (ISA/smbus)? I2C/SMBus

To make the sensors modules behave correctly, add these lines to
/etc/modules.conf:

#----cut here----
# I2C module options
alias char-major-89 i2c-dev
#----cut here----

To load everything that is needed, add this to some /etc/rc* file:

#----cut here----
# I2C adapter drivers
modprobe i2c-i801
# modprobe unknown adapter bt878 #0 [sw]
modprobe i2c-isa
# I2C chip drivers
modprobe lm85
modprobe eeprom
modprobe smbus-arp
# no driver for Nat. Semi. PC87372 Super IO Fan Sensors yet
# sleep 2 # optional
/usr/bin/sensors -s # recommended
#----cut here----

WARNING! If you have some things built into your kernel, the list above
will contain too many modules. Skip the appropriate ones! You really should
try these commands right now to make sure everything is working properly.
Monitoring programs won't work until it's done.

Do you want to generate /etc/sysconfig/lm_sensors? (YES/no): YES
Copy prog/init/lm_sensors.init to /etc/rc.d/init.d/lm_sensors
for initialization at boot time.
[root@localhost dm]# sensors
Philips PAL_BG -i2c-0-61
Adapter: bt878 #0 [sw]
[root@localhost dm]#
-----------------------------------------------------------

подскажите, что делаю не так, как активировать сенсоры температуры?
Re: Мониторинг температуры процессора 13.12.2005 20:29Bomberman мне фот че интересно у мя интеловский сервак

стоит шапка 7.3 вкомпилил в ядро жоско все вазможные чипсеты датчиков... горит нету у тя сенсорс и усе... эт как понимать?
Re: Мониторинг температуры процессора 13.12.2005 23:41Bircoph Похоже, что у вас относительно новое железо и очень старые
lm_sensors, обновите пакет и пересобирите модули сенсоров к
ядру.
Re: Мониторинг температуры процессора 14.12.2005 02:09data2or Bircoph писал(а):

> Похоже, что у вас относительно новое железо и очень старые
> lm_sensors, обновите пакет и пересобирите модули сенсоров к
> ядру.
>

если этот совет для data2or,
поясните пдробнее как пересобрать модули сенсоров к ядру.

Правильно я думаю, что надо качать исходники lm_sensors?
Re: Мониторинг температуры процессора 14.12.2005 05:15Bircoph > Правильно я думаю, что надо качать исходники lm_sensors?

Да, там в readme детально описан весь процесс сборки модулей
и программ пользовательского уровня.
RSS-материал