Работа привода в KDE

Автор: Artjom Дата: 05.03.2008 15:19 Вставляешь диск в привод и Conqueror выдаёт сообщение: Файл или папка /media/НоÐ?ый не существует. Так что открыть содержимое можно только через проводник добираясь до папки media и т.д. Как я понял причина в том что лэйбл диска на русском, в данном случае 'Новый'. Можно ли как-то поправить?
Re: Работа привода в KDE 05.03.2008 21:38Юрий Клещетников Может нужно изменить кодировку системы на cp-1251 ?
Re: Работа привода в KDE 06.03.2008 00:31BigAndy >Так что открыть содержимое можно только через проводник
Э-э-эм.... Что сегодня принято курить? Улыбка
Где вы проводник нашли в пингвинуксе.
Что происходит после команд mount, заданых явно с указанием кодовых страниц ятакже явно?

>Как я понял причина в том что лэйбл диска на русском
Причина в том, что скорее всего диск записан с cp ичной от cp вашей локали.
Re: Работа привода в KDE 06.03.2008 02:06Artjom В Gnome всё работает нормально, значит опять какая-то КеДейовина.
Re: Работа привода в KDE 06.03.2008 02:10Artjom Так сделать что-нибудь можно или только причины остались?
Re: Работа привода в KDE 06.03.2008 09:34peter_ir Так сказали же: смонтировать командой mount с указанием кодировок.
Re: Работа привода в KDE 06.03.2008 12:04Artjom peter_ir писал(а):
> Так сказали же: смонтировать командой mount с указанием
> кодировок.
Пётр, а не могли бы подсказать, где указать необходимую кодировку надо чтобы он автоматом правильно монтировался?
Re: Работа привода в KDE 06.03.2008 12:10peter_ir В опциях команды mount.
mount -t <fstype> -o {опции} device mount_point
и все это есть в "man mount".
Re: Работа привода в KDE 06.03.2008 12:10Юрий Клещетников Если диск создан в Виндовс, то cp-1251 (она же windows-1251, она
же кириллица виндовс).
Возможно команда mnt.....
Re: Работа привода в KDE 06.03.2008 12:38Юрий Клещетников У меня на Рабочем столе пользователя с сеансом KDE
ссылка на раздел жёсткого диска (C:/), поэтому само всё монтируется
без проблем.

Я почитал справку:
Можно использовать команду:
mount /dev/cdrom

Наверное для dvd можно использовать:
mount /dev/dvdrecorder

Я не нашёл об этом статьи, но именно dvdrecorder - это
dvd-привод.

Лучше создайте ссылку как я на десктопе, а то каждый раз будете
работать в досе.
Я нашёл старую болванку, записанную в венде по русски названный диск.
Всё запускается без консоли.
Re: Работа привода в KDE 06.03.2008 12:46BigAndy >mount /dev/cdrom
А если у вас в fstab такого не прописано?
Re: Работа привода в KDE 06.03.2008 13:20Юрий Клещетников Ну так напишите как лучше...
Re: Работа привода в KDE 06.03.2008 15:21Artjom Юрий Клещетников писал(а):
> Ну так напишите как лучше...
Ну что вы, тут так сразу не принято. Нужно всё по капле вымораживать..
Re: Работа привода в KDE 06.03.2008 15:48Artjom Вот fstab:

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
/dev/sda5 /media/Additional ntfs-3g auto,rw,defaults,umask=0000 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0

К какой строке нужно добавить необходимую кодировку (и какую), чтобы DVD-ROM монтировался корректно?
Re: Работа привода в KDE 06.03.2008 16:42peter_ir Сначала надо саму строку добавить.
Re: Работа привода в KDE 06.03.2008 17:02Artjom Поскажите уж теперь как эта строка будет выглядеть. В свойствах примонтированного диска заметил, что устройство /dev/sr0. Уж не так ли:
/dev/sr0 /media/DVD-Rom auto,defaults,locale=ru_RU.WIN-1251 0 0
Это к примеру. Может что-то не так и надо добавить или изменить?
Re: Работа привода в KDE 06.03.2008 19:57peter_ir Вот она из ASP11
/dev/hdc /media/cdrecorder auto user,pamconsole,noexec,noauto,iocharset=koi8-r,managed 0 0

Монтирую командой "mount /dev/hdc".
Re: Работа привода в KDE 06.03.2008 20:48BigAndy >Ну что вы, тут так сразу не принято. Нужно всё по капле вымораживать..
Нет, надо было просто по форуму поискать. Нашли бы с потыщи постов. Зачем повторяться. НуЮ и man никто не отменял.

man mount и man fstab
Re: Работа привода в KDE 07.03.2008 01:25Artjom А может вообще дело в HAL, а затем udev и правило для sr0 с iocharset=koi8-r win-1251 и т.д. Это же automount?
Re: Работа привода в KDE 07.03.2008 09:08peter_ir Можно и с automount и без, и то и другое с записью в fstab и бз нее.
Re: Работа привода в KDE 07.03.2008 09:43BigAndy >А может вообще дело в HAL, а затем udev и правило для sr0
Хм. Обычно правила HAL/udev прописываются для plug-in устройств.
Re: Работа привода в KDE 07.03.2008 11:46peter_ir BigAndy писал(а):

> >А может вообще дело в HAL, а затем udev и правило для sr0
> Хм. Обычно правила HAL/udev прописываются для plug-in
> устройств.
В ASP11 в 10-storage-policy.fdi много строк и для cdrom.
Re: Работа привода в KDE 07.03.2008 12:07Artjom Для CD-ROM в udev правило одно в /etc/udev/rules.d/60-cdrom_id.rules и оно такое
KERNEL=="sr[0-9]*|hd[a-z]|pcd[0-9]*", IMPORT{program}="cdrom_id --export $tempnode"
Так может Automount и fstab тут вообще не причём. Монтируется-то всё нормально, только название диска отображается неверно и Konqueror говорит, что папки &#208;&#65533;&#208;&#190;&#208;?&#209;&#8249;&#208;&#185; нету. И то при старте диска, а если через тот же Konqueror добраться до папки media, куда оно монтируется, то там всё нормально есть папка 'Новый' с содержимым диска. Мо жет я не прав, но может за это отвечает часть правила IMPORT{program}="cdrom_id --export $tempnode"?
Re: Работа привода в KDE 07.03.2008 13:00Ed_Em Если у Вас ASP12, проверьте, работает ли kded (почему-то он не запускается автоматически, так что его надо в автостарт прописывать). Я с 12м игрался, была такая беда с автомонтированием, причем метка диска могла быть любая. Просто писал, что нет такой папки. После запуска kded все нормально открывалось.
Re: Работа привода в KDE 07.03.2008 13:03peter_ir Есть еще оgции монтирования для hal, в /usr/share/hal/fdi/policy/10osvendor, туда можно добавить
желаемые.
Re: Работа привода в KDE 08.03.2008 01:38Artjom Господа, kded работает.
[artjom@localhost ~]$ kded
KDE Daemon (kded) already running.
Так из-за этих глюков с правильной кодировкой меток дисков и k3b диски не форматирует и не жгёт, и Gnomebaker естественно тоже. Остаётся пользоваться Nero Linux, которое почему-то работает без затыков.
Re: Работа привода в KDE 08.03.2008 02:37Bircoph какой нахрен неро?
man growisofs
RSS-материал