K3b и X includes

Автор: Solo Дата: 30.07.2003 10:59 Доброго дня.

Попытался поставить себе k3b-0.9, при запуске ./configure выдается ошибка "невозможно найти X includes. Введите корректый путь"
В ASP9 посмотрел /usr/X11R6/include/X11, у меня там только каталог bitmaps.
В ASP 7.3, который у меня на работе, в этом каталоге еще много всего есть... Соответственно ошибок нет...
Подскажите пожалуйста, что можно сделать?..
Потом решил поставить из RPM --- нужен libGLcore.so.1. Нашел, что этот файл относится к драйверам nVidia, а у меня прекрасно работает
Radeon9Kpro. Может ссылку какую-то надо сделать?
Re: k3b и X includes 30.07.2003 11:15SergeR Поискать rpm-пакет с названием что-то вроде XFree86-devel
Re: k3b и X includes 31.07.2003 09:01МихаилZ Вот поэтому лучше при устанвке выбирать тип установки - Разработка
Все эти мелкие devel пакеты поставятся автоматом
Re: k3b и X includes 21.08.2003 18:16Pink_Punk checking for extra includes... no
checking for extra libs... no
checking for libz... configure: error: not found.
Possibly configure picks up an outdated version
installed by XFree86. Remove it from your system.

Check your installation and look into config.log
А с этим как бороться?
Re: k3b и X includes 21.08.2003 18:19SergeR libz не хватает? Поставь RPM-пакет zlib-devel. Улыбка
Re: k3b и X includes 21.08.2003 18:34Pink_Punk Спасибо,теперь скажите плиз на каком диске я могу найти вот эти пакеты
onfigure: WARNING: libjpeg not found. disable JPEG support.
checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found.
Re: k3b и X includes 21.08.2003 19:06SergeR libjpeg.rpm, libjpeg-devel.rpm а также qt-devel. -devel пакеты как правило на третьем диске.
Re: k3b и X includes 21.08.2003 20:05Pink_Punk Поставил libjpeg.rpm, libjpeg-devel.rpm а также qt-devel, а с меня ещё и требубуют какие-то qt-mt все диски облазил не нашёл.
И в обще может кто-нибудь скажет ВСЕ пакеты которые ещё надо будет доставить???
Re: k3b и X includes 21.08.2003 20:22Pink_Punk checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
Re: k3b и X includes 21.08.2003 20:58Iron ./configure --prefix=/usr --with-qt-dir=/usr/lib/qt-3.1
Re: k3b и X includes 21.08.2003 21:08SergeR qt multithreaded, что-то не находится в дистре ASP9...

ВСЕ пакеты, которые нужно будет поставить? Может поставить уже собранный k3b? Улыбка

поищи в contribs (http://download.asplinux.ru/contribs/9 и далее). Или пропиши этот репозиторий в конфиг yum'а и скажи
---
#yum install k3b
---
И будет щастье.
Re: k3b и X includes 21.08.2003 23:49Pink_Punk Я хочу собрать русский К3Б с помощью спек-файла который тут нашёл.
Re: k3b и X includes 22.08.2003 00:52Woodoo Pink_Punk писал(а):

> Я хочу собрать русский К3Б с помощью спек-файла который тут
> нашёл.

Нахождение недостающих компонентов:
[rpmfind.net]
и|или
---
# man yum
---
Re: k3b и X includes 22.08.2003 01:14rmn Pink_Punk писал(а):

> Я хочу собрать русский К3Б с помощью спек-файла который тут
> нашёл.
Улыбка тот спек-файл для пакета k3b-i18n-ru
А k3b должен собираться отдельно Катается от смеха
Re: k3b и X includes 22.08.2003 11:30Pink_Punk Они оба на одном и том же этаме запарываются.И установка идёт почти одна и та же.
Re: k3b и X includes 22.08.2003 11:51Alexandr Yakunin qt должна быть =>3.1,это условие выполняется?В readme есть сборочные требования.
Re: k3b и X includes 22.08.2003 11:52Pink_Punk Может у кого есть уже скомпилённый RPM русской k3b?
А то чувствую я долго буду с ним копаться.
Re: k3b и X includes 22.08.2003 12:05Pink_Punk Alexandr Yakunin писал(а):

> qt должна быть =>3.1,это условие выполняется?

Конечно выполняется.
Re: k3b и X includes 22.08.2003 12:21Alexandr Yakunin Отправил я тебе бинарник,не мучайся.
RSS-материал