Надо скомпилировать прогу с поддержкой QT4

Автор: Vladimir_N-sk Дата: 15.04.2009 09:14 Скачал с этого сайта и установил ASPLinux 14. При установке выбрал опцию "для разработчиков", причем зашел и открыжил ручками все дополнительные пакеты которые по умолчанию не ставятся.
Хочу скомпилировать некую прогу, она компилируется с поддержкой qt4. Но configure выдает вот такой облом
configure: error: QT4 development, include files no present (into directory /usr/lib/qt4)! Install QT4 library development package.

Это означает что "QT4 library development package" не установился все-таки, хоть я и попытался помаксимуму установить "для разработчиков", или все-таки есть, но надо явно указать путь? Или библиотеку QT4 надо таки отдельно качать устанавливать?

Причем эта прога, скаченная в виде бинарника, работает.
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 11:44peter_ir Что у вас установлено, вам лучше, знать, "rpm -qa".
Может потребоваться установить переменную окружения QTDIR,
на что она должна указывать, сейчас не помню, это можно найти
во всяких README в devel-пакете.
Также этот пакет может содержать скрипты для установки QTDIR,
они записываются в /etc/profile.d.
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 12:54lg Пакет qt-devel (qt4-devel) установлен?
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 13:12Vladimir_N-sk lg Пишет:
-------------------------------------------------------
> Пакет qt-devel (qt4-devel) установлен?

Нет, не стоит. Где взять?
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 13:24blH, yum install qt-devel
как-то так..
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 13:27DimaP
Vladimir_N-sk пишет:
> > Пакет qt-devel (qt4-devel) установлен?
>
> Нет, не стоит. Где взять?



А где вы остальные пакеты системы брали? От туда и этот брать.Улыбка
Устанавливать знаете как?
Вообщем как сказал бы БольшойЭнди:
man yum
yum install qt4-devel

Либо с Федорки 9 брать пакет.
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 13:53Vladimir_N-sk blH, Пишет:
-------------------------------------------------------
> yum install qt-devel
> как-то так..

Получилось как-то так

[root@ASPLinux ~]# yum install qt-devel
Loaded plugins: refresh-packagekit
[download.asplinux.ru]: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.

Хм... ну ладно. Зашел ручками на
[download.asplinux.ru]
там вроде download eсть, клика... не-а..... облом
The requested URL '/i386/updates/14/i386/qt-devel-4.4.3-10.0.140asp.i386.rpm' was not found on this server.

Еще какие-нибудь методы есть?
Я новичок в линуксе, до этого с соляркой только работал.
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 14:08Vladimir_N-sk DimaP Пишет:
-------------------------------------------------------
> А где вы остальные пакеты системы брали? От туда и
> этот брать.Улыбка

Намек понял. Нашелся пакет на диске.
А что надо указать при установке, чтоб по максимуму пакеты установить? Чтоб не искать их потом по загашникам...
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 15:17blH, Vladimir_N-sk Пишет:
-------------------------------------------------------
> А что надо указать при установке, чтоб по
> максимуму пакеты установить? Чтоб не искать их
> потом по загашникам...

Выбрать все пакеты при установке, когда это будет Вам предложено (нажать кнопочку "выбрать пакеты вручную" на одном из экранов и затем отметить все). Только это -- плохой, негодны путь. Поскольку в результате на Ваш компьютер будет установлено какое-нибудь КДЕ, которое нафиг никому не нужно, а жизненно необходимые пакеты вроде shorewall-a или FreeNX сервера, или даже крузадер (прикиньте: в АСПе теперь нету крузадера, да?) всё равно Вам придётся набирать по разнообразным загашникам в дальнейшем.
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 18:40BigAndy Vladimir_N-sk Пишет:
-------------------------------------------------------
> DimaP Пишет:
> --------------------------------------------------
> -----
> > А где вы остальные пакеты системы брали? От туда
> и
> > этот брать.Улыбка
>
> Намек понял. Нашелся пакет на диске.
> А что надо указать при установке, чтоб по
> максимуму пакеты установить? Чтоб не искать их
> потом по загашникам...
yum install * --enablerepo=*
Но берегитесь....
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 19:25DimaP
BigAndy пишет:
> yum install * --enablerepo=*
> Но берегитесь....



B-) ну зачем так над человеком "издеваться"? Катается от смеха:-D:-D
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 19:43BigAndy DimaP Пишет:

> B-) ну зачем так над человеком "издеваться"? Катается от смеха:-D:-D
Издеваться? На строго поставленный вопрос строго сформулированнй ответ!
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 19:44blH, Ну почему сразу "издеваться"? Из АСПа rawhide таким образом всё равно не подцепится, а остальное -- не так страшно. Падумаиш, помойка...
Re: Надо скомпилировать прогу с поддержкой QT4 15.04.2009 19:53BigAndy Вот как делать смс быстро
[asplinux.net]
Re: Надо скомпилировать прогу с поддержкой QT4 16.04.2009 17:45lkanter BigAndy Пишет:
-------------------------------------------------------
> Вот как делать смс быстро
> [asplinux.net]

Ничего не получится. Во-первых украинский МТС, про который там пишут, уже вырубил свой шлюз. Во-вторых, даже когда он работал были задержки минут на 40.
RSS-материал