FlyVideo 3000 (no FM)

Автор: Alcamonster Дата: 18.01.2006 01:10 Не получается настроить ТВ-каналы в tvtime, пишет, что нет сигнала.
Пробовал запускать tvtime-scanner, он также сигнала не обнаружил.
Под виндовсом тюнер работает без нареканий.
Система ASPLinux release 10 (Karelia), Kernel 2.6.12-1.1381.2asp on an i686
Судя по логам, тюнер определяется нормально, драйвер saa7134 подгружается.
В modprobe.conf записано так:
alias char-major-81 saa7134
options saa7134 card=2 tuner=24
Искал ответ и на этом форуме, и в гугле-яндексе, ничего работоспособного не нашел.

по lspci -vv получаем:
========================
00:0a.0 Multimedia controller: Philips Semiconductors SAA7134 (rev 01)
Subsystem: Animation Technologies Inc.: Unknown device 0138
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 32 (4000ns min, 10000ns max)
Interrupt: pin A routed to IRQ 7
Region 0: Memory at dfffb800 (32-bit, non-prefetchable)
Capabilities: [40] Power Management version 1
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=3 PME-


kudzu -p
============
class: OTHER
bus: PSAUX
detached: 0
driver: ignore
desc: "saa7134 IR (LifeView FlyVIDEO30"

class: CAPTURE
bus: PCI
detached: 0
driver: saa7134
desc: "Philips Semiconductors SAA7134"
vendorId: 1131
deviceId: 7134
subVendorId: 5168
subDeviceId: 0138
pciType: 1
pcidom: 0
pcibus: 0
pcidev: a
pcifn: 0
Re: FlyVideo 3000 (no FM) 18.01.2006 20:13chet2002 действительно странно....
все вроде нормально определяется.
У меня аппарат saa7130HL работает нормально. Ядро малец другое 2.6.12-1.1380asp
По kudzu -p
Есть небольшая разница в Вэндерах и
pcibus: 2
Но я не думаю что неработает изза этого.
Скажи свой e-mail я тебе настройки tv-time
вышлю и modrpobe.conf тоже надо кое-что
прописать
Re: FlyVideo 3000 (no FM) 18.01.2006 21:19Alcamonster alcamonster <crazy dog> mail точка ru
Re: FlyVideo 3000 (no FM) 18.01.2006 22:46chet2002 У файла tar.gz расширение
Re: FlyVideo 3000 (no FM) 19.01.2006 02:19lystor chet2002 писал:
> Скажи свой e-mail я тебе настройки tv-time вышлю

И другому народу на форум поделитесь...
Re: FlyVideo 3000 (no FM) 19.01.2006 19:23Alcamonster спасибо за советы,
прописал я в modprobe.conf эти параметры,
но они не заставили тюнер сканировать тв-сигнал.

однако, если в виндовсе запустить программу просмотра тв,
затем перегрузиться в линух и запустить tvtime, то
будет показываться последний выбранный в виндовой проге канал.

P.S.: такое ощущение, что часть устройств в системе не до конца инициализируется.
в частности глюки замечены также и с сетевой карточкой (3Com PCI 3c980C Python-T).
К примеру, если "на холодную" загрузиться сразу в линукс, сеть не работает.
При этом Network Monitor постоянно перемигивается с "подключено" в "отключено",
как по интерфейсу loopback, так и по eth0. Перезагрузка компа с заходом в виндовс
с последущим возвратом к линуксу позволяет сети заработать нормально.
Re: FlyVideo 3000 (no FM) 19.01.2006 22:17chet2002 Какая у тебя мамаша?
Re: FlyVideo 3000 (no FM) 20.01.2006 00:43Alcamonster MSI KT6-Delta rev.2.0
Re: FlyVideo 3000 (no FM) 20.01.2006 22:56Stas Urban Попробуй добавить

/sbin/modprobe tda9887 secam=d

Мне помогло
Мой конфиг:
alias char-major-81 videodev
options i2c-algo-bit bit_test=1
options saa7134 card=2 i2c_scan=1 tuner=38
Плюс отдельно догружаю
/sbin/modprobe tda9887 secam=d

TVTime прекрасно работает. Раньше тоже наблюдал что начинает работать после перезагрузки WIN
Re: FlyVideo 3000 (no FM) 21.01.2006 02:11Alcamonster Грустный( сорри, этот вариант также не прокатил ...

в гугле накопал интересную ссылку, по ней много инфы, буду пробовать
[gentoo-wiki.com]
RSS-материал