Ошибка ide при установке ASP10

Аватар пользователя Aleksey

Добрый день,

Проблема в следующем:
Ставлю ASP10 на ноутбук IBM R40e. При начальной загрузке ядра:

---
ALI15X3: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0x8080-0x8087, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0x8088-0x808f, BIOS settings: hdc:DMA, hdd:pio
---

Далее все виснет глухо ...
Как отключить проверку этого ALI? :-?

Спасибо.

PS
В биосе отключить DMA не могу...

Аватар пользователя McStar

Re: Ошибка ide при установке ASP10

Это, видимо, в биосе надо побаловаться с настройками IDE

Аватар пользователя keng00ru

Re: Ошибка ide при установке ASP10

Это не из-за чипсета. У меня на Toshiba выдаётся то же самое сообщение, потом задержка секунды три, и загрузка продолжается. На ноутбуках такое бывает из-за неправильной поддержки ACPI и APM. Это режимы энергосбережения. Посмотри, что у тебя стоит в BIOS. Попробуй отключить в загрузчике ACPI.
rhgb надеюсь отключен?
Если не поможет, выложи сюда свой /var/log/dmesg.

Аватар пользователя alex_root

Re: Ошибка ide при установке ASP10

Цитата:
Это, видимо, в биосе надо побаловаться с настройками IDE

А резве линух берёт инфу о IDE в БИОС? Может контроллер какой то "редкий", ноутбук всёже...

Аватар пользователя Aleksey

Re: Ошибка ide при установке ASP10

Цитата:
keng00ru пишет:
Посмотри, что у тебя стоит в BIOS. Попробуй отключить в загрузчике ACPI.
rhgb надеюсь отключен?
Если не поможет, выложи сюда свой /var/log/dmesg.

---
В биосе нет возможности "играть" настройками IDE Грустный (нет их там - вот такой ноутбук).

Подскажите каким параметром ядра отключить ACPI?

Пробовал отключать тестирование IDE - результата нет.

Аватар пользователя keng00ru

Re: Ошибка ide при установке ASP10

Вообще нет доступа к BIOS? Не может быть. Сейчас разберёмся... Это не IDE - клянусь! alex_root правду говорит.
В параметрах ядра укажи: acpi=off

Аватар пользователя Aleksey

Re: Ошибка ide при установке ASP10

Цитата:
keng00ru пишет:
Вообще нет доступа к BIOS? Не может быть. Сейчас разберёмся... Это не IDE - клянусь! alex_root правду говорит.
В параметрах ядра укажи: acpi=off

Доступ к биосу есть.
В настройках биоса нет никаких параметров относящихся к IDE... :-?

Аватар пользователя McStar

Re: Ошибка ide при установке ASP10

Цитата:
alex_root пишет:

Цитата:
Это, видимо, в биосе надо побаловаться с настройками IDE

А резве линух берёт инфу о IDE в БИОС? Может контроллер какой то "редкий", ноутбук всёже...

Не знаю, что где берёт, но пока я в БИОСе у себя не выставил native mode для SATA у меня Линух не загрузился.

Аватар пользователя keng00ru

Re: Ошибка ide при установке ASP10

McStar, это у тебя (да и не только у тебя) из-за неправильной реализации поддержки контроллеров SATA. Это вина ядра и его сборщиков. Отсюда и все косяки. А native mode просто отключает этот контроллер и включает режим работы в собственной системе команд.

Аватар пользователя Aleksey

Re: Ошибка ide при установке ASP10

Улыбка

Всем БОЛЬШОЕ СПАСИБО!
acpi=off - как раз то, что нужно ...

Аватар пользователя keng00ru

Re: Ошибка ide при установке ASP10

Цитата:
Aleksey пишет:
Улыбка
Всем БОЛЬШОЕ СПАСИБО!

Да всегда пожалуйста! Приходи ещё!

Аватар пользователя McStar

Re: Ошибка ide при установке ASP10

Цитата:
keng00ru пишет:
McStar, это у тебя (да и не только у тебя) из-за неправильной реализации поддержки контроллеров SATA. Это вина ядра и его сборщиков. Отсюда и все косяки. А native mode просто отключает этот контроллер и включает режим работы в собственной системе команд.

Дык, ты хочешь сказать, что кому-то удалось заставить десятку работать с SATA дисками и IDE одновременно?

Аватар пользователя keng00ru

Re: Ошибка ide при установке ASP10

Я знаю точно, что методом хитрых манипуляций ASPLinux ставится на SATA, а поддержку IDE ещё не отменяли, вроде... Так что получается, что работает.

Аватар пользователя McStar

Re: Ошибка ide при установке ASP10

А манипуляции можно объяснить?

Аватар пользователя keng00ru

Re: Ошибка ide при установке ASP10

Не, McStar, не могу. Но вот здесь этот вопрос очень грамотно разжёвывали:
http://community.asplinux.ru/forum/6/3520
А если там же в поиск залезть, то на неделю раздумий материала наберёшь точно.

Аватар пользователя McStar

Re: Ошибка ide при установке ASP10

ok, спасибо.

RSS-материал