PPP не дает пакеты

Автор: shutdown-h-now Дата: 10.09.2005 22:53 Ситуация такая:
поднял на работе новый dial-in сервер на АСП10 (mgetty+ppp).В настройках там прописал все точно так же, как и было на старом (работавшем) сервере. Но!
Из-под винды на него дозваниваюсь и работаю, а из-под линукса (тоже АСП10) только дозваниваюсь. Соединение устанавливается, потом мой комп и сервер успешно обмениваются несколькими пакетами (по статистике 25-38 пакетов), а через несколько секунд сервер перестает отвечать, не разрывая при этом соединения. До других серверов (например, провайдера интернет) дозвон и обмен проходят нормально. Казалось бы, вывод следует, что дело в сервере, но смущает то, что из-под винды все работает (специально к другу домой бегал проверять).
Какие у кого соображения?
Доп. информация: авторизация pap, файрвол ни при чем, дозваниваюсь kppp или wvdial - без разницы, раньше (при старом сервере) все шло ОК.
Поделитесь, плиз, мыслями...
Re: PPP не дает пакеты 11.09.2005 07:24Neonovice Малоинформативно.
Re: PPP не дает пакеты 11.09.2005 10:36leXa >Малоинформативно.
$ pppd call my_linux_server и весь сеанс как на ладони.
+ неплохо бы взглянуть на кусок из лога сервера соответствующий этому сеансу.
+ проанализировать RX-TX-ERRORS и прочие отчеты модема.
+ возможно, придется погонять модемные тесты на качество связи.
Работы непочатый край Улыбка
ЗЫ Если все это не для игрулек, а для дела, лучше с модемом
вообще не связываться и попробовать другие возможности доступа.
Re: PPP не дает пакеты 15.09.2005 17:06shutdown-h-now Печально, но видимо дело было в com-порте.
Переставил модем с ttyS0 на ttyS1 - все заработало.
Но все равно не понятно, из-под винды-то коннект шел... Грустный
Re: PPP не дает пакеты 06.06.2006 10:43shutdown-h-now Спасибо за ссылку на мою же ветку Улыбка
Проблему действительно можно решить и так.
Теперь, кстати, выяснил, что не только с dial-up, но и с vpn
RSS-материал