ASP10, KDE и сеть

Автор: Renoir Дата: 01.08.2005 17:29 Купил версию Express, разбираюсь.
В Gnome сеть худо-бедно работает, только одна машина в сети не открывается, мол, не хватает прав. Почему - не ясно.
Просматриваю сеть прямо из файлового менеждера.
А вот в KDE файловый менеджер сначала требовал запустить сервис lisa - я настроил, запустил. Теперь показывает имена машин в сети, а вот к папкам не пускает, ругается, что не может найти и запустить какой-то kio_smb. Что это такое и как его запустить?
И вообще, есть какие-нибудь альтернативные методы просмотра сети или монтирования сетевых папок?
И как настроить самбу, чтобы отображались русские сетевые номера?
Re: ASP10, KDE и сеть 01.08.2005 17:58lystor Renoir писал:
> И вообще, есть какие-нибудь альтернативные методы просмотра сети
man smbclient

или монтирования сетевых папок?
man smbmount

А вообще mc (F1) Улыбка

> И как настроить самбу, чтобы отображались русские сетевые номера?
Поиск по форуму
Re: ASP10, KDE и сеть 01.08.2005 18:29Renoir А mc нормально показывает сетевые ресурсы, только с русскими именами проблемы. Но вот писать на эти ресурсы не хочет...
Я так понимаю, что силами KDE, без ручного монтирования, сеть не посмотреть?
Жаль, нет в дистрибутиве программки Linneighborhood, она помогала решать такие проблемы без ручного ковыряния.
В общем, разочарован слегка. Пора бы уже, к 10 номеру дистрибутива, пофиксить эти проблемы. сколько лет, а воз и ныне там.
Что интересно, простенький дистрибутивчик blin в сети себя чувствует без проблем, правда, там Gnome.
Re: ASP10, KDE и сеть 01.08.2005 19:23lystor Renoir, специально для того, чтобы Вам ответить, поставил KDE
Поехали. Имеем:
kdebase-3.3.1-6.1asp
samba-client-3.0.10-1.10asp
mc-4.6.1-0.14.0.100asp
kernel 2.6.11-1.35asp
Кодировка везде ru_RU.cp1251

> А mc нормально показывает сетевые ресурсы, только с русскими именами проблемы.
В этом Вы совершенно правы - русские имена mc нормально не отображает, но только с win2k, XP. С 9Х не пробовал, с серверами samba все работает прекрасно.
Пересобирать еще не пробовал, но, возможно, проблема будет решена после этой операции.

> Но вот писать на эти ресурсы не хочет...
mc пишет на все сетевые ресурсы, даже на те, которые в своем составе имеют нечитаемые символы кириллицы.

> Я так понимаю, что силами KDE, без ручного монтирования, сеть не посмотреть?
Без проблем:
smb://user_name@host_name/share_name
Чтобы "ручками" не вводить, настройте lisa.
Все открывается прекрасно, символы киррилицы везде корректно отображаются.

Из консоли:
smbclient -L hostname -U username - просмотр списка доступных ресурсов;
smbclient //hostname/sharename -U username - работа с ресурсом;

> Жаль, нет в дистрибутиве программки Linneighborhood, она помогала решать такие проблемы без ручного ковыряния.
Что Вам мешает ее скачать, установить и пользоваться?! Только вот смысла не вижу.
Не хотите ресурс ручками постоянно монтировать - настройте autofs.

> В общем, разочарован слегка. Пора бы уже, к 10 номеру дистрибутива, пофиксить эти проблемы. сколько лет, а воз и ныне там.
Что фиксить, если все работает?

Настройка /etc/samba/smb.conf
unix charset = cp1251
dos charset = 866
display charset = cp1251
Re: ASP10, KDE и сеть 02.08.2005 12:13Alex_S Попробуй Smb4k, немного придется помучится с этим бумажником, но потом все отлично работает и с русскими именами тоже.
Re: ASP10, KDE и сеть 02.08.2005 14:28Renoir > Но вот писать на эти ресурсы не хочет...
>mc пишет на все сетевые ресурсы, даже на те, которые > своем составе имеют нечитаемые символы кириллицы.

Мда. Ответ с пользой, что называется. Вот, понимаете, не пишет mc в сеть, а русские ресурсы даже и не открывает. Не пишет.



>тобы "ручками" не вводить, настройте lisa.
>Все открывается прекрасно, символы киррилицы везде >корректно отображаются

Выше я уже писал:

А вот в KDE файловый менеджер сначала требовал запустить сервис lisa - я настроил, запустил. Теперь показывает имена машин в сети, а вот к папкам не пускает, ругается, что не может найти и запустить какой-то kio_smb


Ничего не открывается, ничего не отображается. Возможно, у вас работает, но я не хакер и не собираюсь им быть. У меня просто - либо работает, либо не работает.
Re: ASP10, KDE и сеть 02.08.2005 14:35keshaLG мда,.... ну что вы все напали на новичка?

1. Что бы КДЕ нормально работал с smb:// - обнови самбу (мне помогло - yum -y update samba)!
2. Попробуй правда smb4k - рульная вещь
Re: ASP10, KDE и сеть 02.08.2005 14:57lystor Renoir писал:
> Вот, понимаете, не пишет mc в сеть
Доступ не запись в ресурс есть?
Имя пользователя и пароль указываете при открытии ресурса или под гостевой учетной записью работаете?

>а русские ресурсы даже и не открывает. Не пишет.
Какая у Вас версия mc, kdebase, samba-client?
Кодировка какая в системе используется?
К ресурсу под управлением какой ОС пытаетесь подключиться?

> Теперь показывает имена машин в сети, а вот к папкам не пускает, ругается, что не может найти и запустить какой-то kio_smb. Что это такое и как его запустить?
Обновите samba-client.

to keshaLG
Зачем же всю samba обновлять?

> Ничего не открывается, ничего не отображается.
> Возможно, у вас работает, но я не хакер и не собираюсь им быть.
Я тоже не хакер.

> У меня просто - либо работает, либо не работает.
Да это у всех так
Re: ASP10, KDE и сеть 02.08.2005 15:20Renoir smb4k - есть пакет для ASP или подойдёт от FC?

>Доступ не запись в ресурс есть?
>Имя пользователя и пароль указываете при открытии >ресурса или под гостевой учетной записью работаете?

Ни слова не понял. Улыбка Паролей в сети на доступ нет, всё работает в других дистрибутивах, достаточно включить dhcp.

>а русские ресурсы даже и не открывает. Не пишет.
>Какая у Вас версия mc, kdebase, samba-client?
>Кодировка какая в системе используется?
>К ресурсу под управлением какой ОС пытаетесь >подключиться?

Граждане хорошие, я понятия не имею, какие версии в официально купленном дистрибутиве уже 10-й версии! Мне это абсолютно безразлично. Я хочу только свободно работать с документами по сети. Всё. В данной ситуации - факт, что ASP 10 не может этого обеспечить без шаманства и плясок с бубнами. Времени не хватило? Не знаю. Уж три строчки с настройкой для отображения русских имён по умолчанию сделать можно было...

Поэтому - в печь. И крест на будущее.
Re: ASP10, KDE и сеть 02.08.2005 17:36Renoir smb4k тоже не работает. при попытке примонтировать ресурс получаем:
smbmnt must be installed suid root for direct user mounts (500,500)
smbmnt failed: 1
Для меня - китайская грамота. Как этот suid присобачить - без понятия.
Кстати, с доступом к win разделам в ASP10 такая же паранойя - юзера не пускают.
Что интересно, в Greenhorn 10 такого нет. Всё работает.
Re: ASP10, KDE и сеть 02.08.2005 17:47lystor Renoir писал:
> smbmnt must be installed suid root for direct user mounts
Поищите по форуму - расписано, что делать

> Кстати, с доступом к win разделам в ASP10 такая же паранойя - юзера не пускают.
Править /etc/fstab для своей системы:
/dev/hdd1 /mnt/win_c ntfs ro,noauto,user,iocharset=cp1251,umask=0000 0 0
/dev/hdd5 /mnt/win_d vfat rw,noauto,user,iocharset=cp1251,codepage=866,quiet,umask=0000 0 0
Re: ASP10, KDE и сеть 02.08.2005 18:23Renoir ОК, в Gnome появились русские названия сетевых ресурсов, хотя по-прежнему, не все можно открыть посмотреть.

Теперь что касается smb4k. Работает. В предпросмотре самой smb4k все русские файлы видны отлично. Но когда они монтируются, то в Konqueror русские имена - кракозябры. Может, вот это:
unix charset = cp1251
dos charset = 866
display charset = cp1251

не соответсвует действительности? Уж больно похожи кракозябры на неправильное отображение utf8...
Re: ASP10, KDE и сеть 02.08.2005 18:31lystor Какая у Вас кодировка? Уже спрашивал.
Конфиг надо настраивать под Вашу систему. Это - под систему с кодировкой cp1251.
Re: ASP10, KDE и сеть 03.08.2005 14:59Renoir Как узнать, какая кодировка? Ставил молча, что предлагал установщик.
Re: ASP10, KDE и сеть 03.08.2005 15:23lystor /etc/sysconfig/i18n один из вариантов
Re: ASP10, KDE и сеть 04.08.2005 13:40Renoir Всё правильно, кодировка cp1251.
Роли не играет. Всё равно примонтированные сетевые ресурсы отображаются кракозябрами.
Re: ASP10, KDE и сеть 04.08.2005 13:53lystor Renoir писал:
> Всё равно примонтированные сетевые ресурсы отображаются кракозябрами.
Вы только что сообщили нам, сами того не осознавая, немаловажную деталь - примонтированные сетевые ресурсы.
А как Вы их монтируете - покажите полную команду.
А если не монтировать?
Konqueror их тоже некорректно по сети отображает? smb://user_name@host_name/share_name
В терминале тоже некорретно отображаются?
Сперва в текстовом режиме попробуйте (ctrl+alt+f1 например):
smbclient -L hostname -U username - просмотр списка доступных ресурсов;
smbclient //hostname/sharename -U username - работа с ресурсом;

Samba обновили до samba-3.0.10-1.10asp?
unix charset = cp1251
dos charset = 866
display charset = cp1251
прописали?
Re: ASP10, KDE и сеть 04.08.2005 14:02xfn >> какой-то kio_smb

Обновите КДЕ, была такая ошибка, после обновления все ОК
Re: ASP10, KDE и сеть 04.08.2005 16:46Renoir Монтирую так: mount -t smbfs //SERVER/Документы /mnt/docs -o rw,username=Myname,workgroup=MYGROUP,iocharset=cp1251,codepage=cp1251

Понятно, что Myname и MYGROUP - это реальные названия. Пароля нет.

Что получаем - сами имена сетевых папок русские. А вот файлы в них кракозябрами.

Монтирую с помощью smb4k - то же самое, очень похоже на кодировку utf8, отображённую локалью cp1251. Но смена в настройках самбы на utf8 ничего не даёт.


>Konqueror их тоже некорректно по сети >отображает?


Вообще не отображает. Писал выше.

>smb://user_name@host_name/share_name
>В терминале тоже некорретно отображаются?

Что есть host_name? Что есть share_name?
Вот это - //SERVER/Документы и Myname вообще ничего не показывает.


>smbclient //hostname/sharename -U username >- работа с ресурсом;

smbclient //SERVER/Документы -U Myname
Отлично показывает все русские имена файлов в терминале. Только что это даёт?



Теперь что касается обновления. Хотя инет доступен, но yum пару раз дёргается и вываливается с сообщением, что ну никак не может достичь репозитория.
И вообще - я не хочу обновлять ничего через инет. Принципиально. Представим, что у меня только GPRS через мобильник и трафик очень дорогой... Ну кто-то же тестировал систему, у него работало.
Re: ASP10, KDE и сеть 04.08.2005 17:07lystor Renoir писал:
> mount -t smbfs //SERVER/Документы /mnt/docs -o rw,username=Myname,workgroup=MYGROUP,iocharset=cp1251,codepage=cp1251
У меня без проблем ваш вариант работает

Хотя правильнее codepage=866. Рабочую группу можно не указывать.

Вы не ответили на эти вопросы:
Без монтирования попробуйте.
Konqueror их тоже некорректно по сети отображает? smb://user_name@host_name/share_name
В терминале тоже некорретно отображаются?
Сперва в текстовом режиме попробуйте (ctrl+alt+f1 например):
smbclient -L hostname -U username - просмотр списка доступных ресурсов;
smbclient //hostname/sharename -U username - работа с ресурсом;
RSS-материал