Проблемы с установкой

Автор: Fizik Дата: 05.07.2008 09:02 скачал firefox-3.0.tar.bz2 немнго непонятно как ставить, после хаждения по сайтам приступил к установке теперь он стал требовать gtk+ скачал gtk+-2.12.11.tar.gz а эта зараза требует ещё
Requested 'glib-2.0 >= 2.13.5' but version of GLib is 2.10.3
Requested 'pango >= 1.17.3' but version of Pango is 1.12.3
Requested 'cairo >= 1.2.0' but version of cairo is 1.0.2
yum находит только старые версии, в инете не нашол
чо делать???
Re: проблемы с установкой 05.07.2008 11:29BigAndy >чо делать???
Для начала раcсказать про uname -a
установить из тарбола (если есть)
Re: проблемы с установкой 05.07.2008 20:18Fizik >Для начала раcсказать про uname -a
непонял можно подробнее

>установить из тарбола (если есть)
говорю же ненашол

самое интересное почему yum находит только старые версии
Re: проблемы с установкой 05.07.2008 21:12BigAndy >самое интересное почему yum находит только старые версии
Потому что так у вас настроены репозитарии.

>можно подробнее
Рассказать, что выдает uname -a
Re: проблемы с установкой 06.07.2008 10:31Юрий Клещетников чо делать???
Обновлять с ФОКСОМ ещё и эти пакеты: glib, pango, cairo до нужной версии.
А потом смотреть, может они тоже "захотят" что-то посвежее.
В общем можно постепенно подкачивать и пробовать ставить.
Но лучше уж подсоединиться к хорошей сети и через yum update ...rpm
Re: проблемы с установкой 07.07.2008 01:00Fizik Юрий проблема какраз именно с этими пакетами glib, pango, cairo
yum их новые версии не находит; скачал ихние исходники tar.bz2 новые версии но они нормально не ставятся. glib поставил как написано в инструкции но установленая версия не видится с другими тоже геморой, в инете прочитал что именно при установке glib из исходников потом нужно какойто файл редактировать (я непонял) с RPM этого не надо и так будет всё нормально.
Вобщем буду разбираться, читать всякую хрень.
Я в линуксе новичок 2 недели назад поставил сплошные проблемы надеюсь новые версии линукса будут легче.
Re: проблемы с установкой 07.07.2008 01:10BigAndy >Вобщем буду разбираться, читать всякую хрень.
> надеюсь новые версии линукса будут легче
Так в телепатическом сне сообществу до сих пор не удлось понять, что за линукс вы пользуете, ибо упорно скрываете вывод `uname -a`
Re: проблемы с установкой 07.07.2008 01:37Fizik [root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.17-1.2157.1asp #1 Fri Aug 11 03:02:11 EEST 2006 i686 athlon i386 GNU/Linux
[root@localhost ~]#
Re: проблемы с установкой 07.07.2008 01:56Fizik вот здесь чото написано про glib но я немного непонимаю [www.opennet.ru]
Re: проблемы с установкой 07.07.2008 09:18BigAndy Установите репозитарии от ливны и АСП, обновите yum update соответсвующие пакеты.
Либо скачайте бинарную сборку со статическими библиотеками. FireFox b1 у нас работает на всех машинах, даже на АСП11.2, правда ручаться не могу, что они с родными библиотеками.
Re: проблемы с установкой 07.07.2008 12:32Fizik >Установите репозитарии от ливны и АСП.
ссылки какие для добавления новых репозитариев

yam это конешно хорошо но хотелось бы разобраться почему не получаеться из скаченых исходников, я уже почти разобрался оказывается что при установке из исходников файлы устанавливаются в другое место и система их в упор не видит и использует старые. Чтобы видела новые при установке других нужно дать каманду: export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig
после этого видит (недолго).
Таким образом я установил пакеты: glib, pango, cairo но теперь не ставится gtk+ когда даёш команду ./configure она в конце пишит:
checking for GLIB - version >= 2.13.5...
*** 'pkg-config --modversion glib-2.0' returned 2.16.4, but GLIB (2.10.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.13.5 or better is required. The latest version of
*** GLIB is always available from [ftp.gtk.org].
[root@localhost gtk+-2.12.11]#

насколько я понял она хочет чтобы я удалил старую версию и при этом чтобы все другие компоненты системы видили новую версию а как это сделать я незнаю.?

Я с линуксом только начал знакомится может что нетак делаю или думаю подскажите.
RSS-материал