Cedega и asplinux12

Автор: aes78 Дата: 17.01.2008 22:56 cedega не идет под asp12 или это только у меня? С чем это может быть связано? Точнее она идет, но в ней нельзя ничего загрузить, даже то, что всегда в ней грузилось.
Re: cedega и asplinux12 21.01.2008 13:15roman1976 У меня те же проблемы в Мандриве. Может быть движок не запущен? Где брали цедегу?
Re: cedega и asplinux12 22.01.2008 10:47AlastorTower Поставил недавно ASPLinux 12 и Cedega 6.0 - все работает (до этого "гамал" через Cedega 6.0 но в ASPLinux 11.2 - разницы никакой не заметил)!!!
Re: cedega и asplinux12 24.01.2008 00:02aes78 движок стоит, работает везде - и в 11.2, и в убунту, и в федоре 8. Где брал - уже не помню. Думал, может что с установкой, все снес, все конфиги, связанные с седегой удалил, поставил по новому, все то же самое
Re: cedega и asplinux12 28.01.2008 23:47aes78 Вот такое вот в консоли выдается:
---
/usr/lib/transgaming_cedega/gddb.py:24: RuntimeWarning: Python C API version mismatch for module gddb_parser: This Python has API version 1013, module gddb_parser has version 1012.
import gddb_parser
wine: Unhandled exception, starting debugger...
---
Последняя строка не кончается бесконечно. Я так понимаю, что версия python C API не совпадает с модулем gddb_parser, но как добиться их совмещения - не понятно.
Re: cedega и asplinux12 31.01.2008 09:16aes78 Снес версию 6.0.2, поставил 5.2.10, теперь под пользователем седега вообще не запускается
---
cedega
/usr/lib/transgaming_cedega/gddb.py:19: RuntimeWarning: Python C API version mismatch for module gddb_parser: This Python has API version 1013, module gddb_parser has version 1012.
import gddb_parser
Traceback (most recent call last):
File "/usr/lib/transgaming_cedega/Point2Play_gui.py", line 2371, in <module>
Point2Play_gui_ref = Point2Play_gui( Point2Play.Point2Play( config_file) )
File "/usr/lib/transgaming_cedega/Point2Play.py", line 360, in __init__
raise badConfigFile( _("Missing options %s";-) % e.value )
AttributeError: 'NoOptionError' object has no attribute 'value'
---
а под рутом запускается и игры идут, хотя ту же строчку, что в 6.0.2 пишет
---
cedega
/usr/lib/transgaming_cedega/gddb.py:19: RuntimeWarning: Python C API version mismatch for module gddb_parser: This Python has API version 1013, module gddb_parser has version 1012.
import gddb_parser
grep: write error: Обрыв канала
/usr/lib/transgaming_cedega/new_install_gui.py:341: GtkWarning: Icon cache '/usr/share/icons/hicolor/icon-theme.cache' is invalid

response = gtk.Dialog.run( self.widgets["install"] )
/usr/lib/transgaming_cedega/new_install_gui.py:341: GtkWarning: Icon cache '/usr/share/pixmaps/hicolor/icon-theme.cache' is invalid

response = gtk.Dialog.run( self.widgets["install"] )
---
Можно как-то перевести процесс под пользователя?
Re: cedega и asplinux12 20.03.2008 21:25Labaman Дело в том что версия 5.2.10 - на ней еще мой дедушка в старкрафт играл =)) Шутка. Ну а если серьезно, то для Cedega 5.2.10 требуеться более старая версия интерпритатора Python и сопутстыующих библиотек (извечная проблема совместности "снизц вверх" на Linux). Так что у Вас есть 2 варианта - либо грохнуть Python и его модули, и поставить более старый (1.5.х вместо текущей 2.5.х), но тогда с ним грохниться еще много чего нужного и полезного... Либо использовать версию Cedega 6.0.2 или новее. Лично я предпочитаю последнее.
У меня с настройкой и использование Cedega в ASP никаких особо тяжких проблем не возникло - поставил cedega 6.0.2-1 (small), собранную под RedHat, обновил движок до 6.0.5, при первом запуске дал добро на обновление всего остального (при первом запуске можно обновиться и без регистрации на их сайте). Далее из-за не очень мирного сосуществования ALSA и ASP (в некоторых случаях приложения и игры, запущенные в эмуляторе могут даже зависать!) в настройках (Global Settings) выставил использовать звуковой драйвер OSS (поумолчанию стоит ALSA) и все - никаких проблем...
RSS-материал