Чтобы не мудрить...

Аватар пользователя Profan

Чтобы не мудрить с недостающими пакетами, при установке выбрал ВСЕ.
Поставил. А КДЕ нет... Это как понимать?
Переставил и ручками выбрал нужные.
Попробовал обновить.
http://community.asplinux.ru/forum/1/50414/
Не получилось. Чего-то не хватает...
Может керосина? (в смысле у меня Улыбка )

И эта фраза из инструкции непонятна:
"Будьте внимательны, автоматическое обновление ядра системы утилита yum не производит."

Как тогда быть?

Аватар пользователя Tigro

Re: Чтобы не мудрить...

А вы выбирали ВСЕ из ВСЕХ ПАКЕТОВ или только из РЕКОМЕНДУЕМЫХ?

Аватар пользователя Profan

Re: Чтобы не мудрить...

Tigro:
"А вы выбирали ВСЕ из ВСЕХ ПАКЕТОВ или только из РЕКОМЕНДУЕМЫХ?"

Вопрос немного поставил в пупик. Напрягаюсь...
Выбрал "Разработка"
В окне установщика список разделов с пакетами.
В верху в оконце написано "Рекомендуемые" и стрелка рядом.
Я выбрал ВСЕ. Потребовало 4076 (??) МБ если не ошибаюсь...
И пошел дальше. Все стало и в Гноме работает.
Хотел КДЕ загрузить, а его в списке нет...
Вот и вопрос.
Сейчас переставляю (комп рядом, благо время есть) и выбрал ручками дополнительные пакеты.
Убирать ненужные не рискнул. Уже наступил на эти грабли.
Лучше потом семь раз отмерю, а потом удалю...

Аватар пользователя Tigro

Re: Чтобы не мудрить...

Так вот там где в оконце написано "Рекомендуемые", можно выбрать "все пакеты", ну и соответственно галочки поставить кажется у 5 или шести пунктов всего.

Аватар пользователя keng00ru

Re: Чтобы не мудрить...

Цитата:
галочки поставить кажется у 5 или шести пунктов всего.

А потом не забыть полностью развернуть все категории и, пройдясь с верху до низу, снять галочки со всех пакетов, находящихся на дисках 4 и 5. Катается от смеха
Ох и загаженная же системка получится! Самое интересное, что использоваться из всего этого хлама будет процентов 10, как максимум, а о назначении 4-5 тысяч установленных пакетов никто никогда и не узнает.

P.S.: И вообще, Profan, зря ты эту тему поднял. Злой я уже две недели на ASP именно из-за этого. Сейчас опять ругаться начну нецензурно. Блюёт

Аватар пользователя Tigro

Re: Чтобы не мудрить...

Андрей, давай врубай фильт обратно, сейчас Серж будет крыть всех, от юзеров до патриархов.Улыбка

Да не обязятельно снимать галочки для 4 и 5 диска...

Аватар пользователя Tolstik

Re: Чтобы не мудрить...

Цитата:
Злой я уже две недели на ASP именно из-за этого. Сейчас опять ругаться начну нецензурно

нетерпелив ты, братец Улыбка мне тоже пришлось как-то пару дней ухлопать на подбор оптимального набора пакетов (с учетом того, что когда отмучаешься с пакетами, инсталятор глюкал и ага!). Зато потом, когда список на дискетте, установка просто отдых. Если еще бы kikstart вернули, было бы вобще супер.
А все свое недовольство, имхо, нужно обрушить на эту толстую тетку по имени Федора - оттуда все неприятности наследуются

Аватар пользователя Profan

Re: Чтобы не мудрить...

Нет. Не надо ставить галочки. Они сами ставятся на всех необходимых.
Но КДЕ я там не увидил.
4 и 5 диски установщик не запрашивал.
Так что же такое ВСЕ ???

keng00ru:
"Ох и загаженная же системка получится!"

Почему загаженная?
Места на современных дисках хоть отбавляй.
Ну и пусть лежат эти ненужные пакеты.
Когда понадобится какой либо - вот он...
Ну конечно иероглифы китайские не нужны.

Вот сейчас на другом компе пробую стандартный набор "Разработка"
обновить.
И как результат:
ошибка: Неудовлетворенные зависимости:
htmlview нужен для system-config-date-1.7.13-0.fc3.1
htmlview нужен для system-config-services-0.8.21-0.fc3.1
htmlview нужен для system-config-users-1.2.28-0.fc3.1
Это теперь их надо искать и доставлять.
А есть ли они на дисках АСП10 ???

А ручками когда выбираещь дополнительные - установщик не раз глюкал...
И все сначала.

Аватар пользователя keng00ru

Re: Чтобы не мудрить...

Цитата:
мне тоже пришлось как-то пару дней ухлопать на подбор оптимального набора пакетов

Пару дней?! Пару дней?!?!?! Сколько с момента выхода десятки прошло? Я до сих пор ничего не могу собрать так, как мне надо! Позавчерашние и вчерашние разборки с пакетами дали мне почти то, что я хочу, но с половиной нерабочего софта. Девятку я, помнится, за неделю уговорил. До сих пор пользуюсь. А опыта-то тогда у меня явно меньше было. Может с опытом приходят повышенные требования и предвзятость?

Цитата:
оттуда все неприятности наследуются

Федора тут не при чём. Она тоже женщина несчастная. Неприятности все от того, что пользователи, привыкшие в Window$ к постоянным обновлениям софта (без этого у него, как известно, ничего не стоит), требуют от разработчиков дистрибутивов всё новых и новых версий. Пусть в ущерб качеству, но зато с ещё более голубым экраном и ещё более дебил-френдли инсталлятором. Разработчики же просто не успевают настроить и отшлифовать всё. Результат мы имеем. Точнее, он нас. В дистрибутив впихиваются все самые новые версии пакетов, но их набор абсолютно не сбалансирован, да и инсталлятор доделать не успевают, потому что иначе, к моменту выхода дистрибутива, "пользователи" (слово-то какое мерзкое) взвоют: "АСП - ацтой, там KDE 3.3.1, а в инете уже 3.3.2 лежит!". Потом, они, правда, всё равно воют: "А чё он сам не ставица и ещё какие-то два диска хочет?". Нормальное такое желание и рыбку съесть и ... всё остальное.

Аватар пользователя alex_root

Re: Чтобы не мудрить...

Цитата:
Нет. Не надо ставить галочки. Они сами ставятся на всех необходимых.
Но КДЕ я там не увидил.

Выбираешь пару КДЕшных пакетов, остальное потянется автоматом.

Пока не поздно, нужно начать собирать подписи за то что бы к ASPLinux11 прикрутили kpackager или synoptic

Аватар пользователя keng00ru

Re: Чтобы не мудрить...

Цитата:
Почему загаженная?

То, что лишние пакеты занимают место на диске - это только цветочки. Они же не просто так лежат. Они ещё и жрать просят. Точнее, не просят - сами берут. А жрут они много. В результате мы получаем тот же Window$ - абсолютно неуправляемую и неконтролируемую систему.

Цитата:
нужно начать собирать подписи

Алекс, нужно начинать собирать подписи, чтобы 11-ую версию сделали на одном диске и выделили год на её тестирование. Глядишь, тогда не придётся начинать обновление системы с обновления программы обновления. Катается от смеха Ну, Вы поняли, я про yum update yum

Аватар пользователя alex_root

Re: Чтобы не мудрить...

Цитата:
Алекс, нужно начинать собирать подписи, чтобы 11-ую версию сделали на одном диске

Про FoXLinux слышал? На одном диске и чисто КДЕ. Правда напряг с русификацией (kde-i18n-Russian от Тигро не помешал бы ;))) Вот разозлюсь и куплю!

Аватар пользователя Profan

Re: Чтобы не мудрить...

Error: missing dep: htmlview for pkg system-config-services
Error: missing dep: libavformat.so for pkg k3b
Error: missing dep: htmlview for pkg system-config-users
Error: missing dep: libavcodec.so for pkg k3b
Error: missing dep: htmlview for pkg system-config-date

Пакет htmlview нашел и установил.
А вот libavcodec.so for pkg k3b и libavformat.so for pkg k3b
на дисках нет...
Где их брать?

Аватар пользователя Tolstik

Re: Чтобы не мудрить...

Цитата:
Пока не поздно, нужно начать собирать подписи....

все подписи - вот сюда

Тут же и голосуйте

Аватар пользователя alex_root

Re: Чтобы не мудрить...

Цитата:
А вот libavcodec.so for pkg k3b и libavformat.so for pkg k3b
на дисках нет...
Где их брать?

Для k3b они не требуются.

Аватар пользователя Archont

Re: Чтобы не мудрить...

Цитата:
keng00ru пишет:
Неприятности все от того, что пользователи, привыкшие в Window$ к постоянным обновлениям софта (без этого у него, как известно, ничего не стоит), требуют от разработчиков дистрибутивов всё новых и новых версий. Пусть в ущерб качеству, но зато с ещё более голубым экраном и ещё более дебил-френдли инсталлятором. Разработчики же просто не успевают настроить и отшлифовать всё. Результат мы имеем. Точнее, он нас. В дистрибутив впихиваются все самые новые версии пакетов, но их набор абсолютно не сбалансирован, да и инсталлятор доделать не успевают, потому что иначе, к моменту выхода дистрибутива, "пользователи" (слово-то какое мерзкое) взвоют: "АСП - ацтой, там KDE 3.3.1, а в инете уже 3.3.2 лежит!". Потом, они, правда, всё равно воют: "А чё он сам не ставица и ещё какие-то два диска хочет?". Нормальное такое желание и рыбку съесть и ... всё остальное.

В том числе и по этой причине сижу до сих пор на 7.3 и потихоньку по мере надобности компилирую обновления.
И мне очень сухо и комфортно Улыбка)

Аватар пользователя keng00ru

Re: Чтобы не мудрить...

Цитата:
И мне очень сухо и комфортно

Ну, это смотря на какой машине. Для P-4 ASP 7.3 всё-таки очень сильно перекраивать нужно. Проще уже сразу за LFS взяться. Улыбка Не смешно, кстати. К этому всё и катится.

Аватар пользователя Tigro

Re: Чтобы не мудрить...

Цитата:
libavcodec.so for pkg k3b и libavformat.so for pkg k3b

Это пакет ffmpeg

Аватар пользователя Profan

Re: Чтобы не мудрить...

Скачал и попробовал установить.

[root@mobil home]# /usr/share/mc/extfs/rpm run /home/ffmpeg-1.4.9-0.20050427.1.1.fc3.i386.rpm INSTALL
Installing ""'/home/ffmpeg-1.4.9-0.20050427.1.1.fc3.i386.rpm'""
ошибка: Неудовлетворенные зависимости:
libImlib2.so.1 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3
liba52.so.0 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3
libfaac.so.0 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3
libfaad.so.0 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3
libpostproc.so.0 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3

Неплохая тренировка при обновлении.
Что-то тут не так. Ведь есть диск обновлений и на нем это добро должно присутствовать...

Аватар пользователя sergeil

Re: Чтобы не мудрить...

Profan писал:
>> Скачал и попробовал установить.

Кстати, если не секрет, откуда скачали?

>> [root@mobil home]# /usr/share/mc/extfs/rpm run /home/ffmpeg-1.4.9-0.20050427.1.1.fc3.i386.rpm INSTALL
Installing ""'/home/ffmpeg-1.4.9-0.20050427.1.1.fc3.i386.rpm'""

Очень ветиевато... Обычно пишут значительно проще:

root# rpm -i ffmpeg-1.4.9-0.20050427.1.1.fc3.i386.rpm

Зачем использовать plug-in mc, если синтаксис основной программы (rpm) проще и понятнее?

>> ошибка: Неудовлетворенные зависимости:
>> libImlib2.so.1 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3
>> liba52.so.0 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3
>> libfaac.so.0 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3
>> libfaad.so.0 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3
>> libpostproc.so.0
>> нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3

>> Неплохая тренировка при обновлении.

Ну ... давайте будем честными... Инсталлирование пакета и освежение - далеко не одно и тоже. Что-бы действительно только освежить (обновить установленные) пакеты, Вы должны были набрать аналог

root# rpm -F ffmpeg-1.4.9-0.20050427.1.1.fc3.i386.rpm

Тогда, если старая версия пакета не установлена, то новая версия просто проигнорируется. Так у Вас был установлен ffmpeg или нет? Это важно...

>> Что-то тут не так. Ведь есть диск обновлений и на нем это добро должно присутствовать...

Это "добро" может присутствовать в виде отдельных пакетов как на диске обновлений, так и на установочных дисках дистрибутива... При обновлении рекомендуют оба репозитария (основной) и обновлений делать доступными.
Улыбка

Кстати:
...
>> libfaad.so.0 нужен для ffmpeg-0.4.9-0.20050427.1.1.fc3
Пакет faad*.i386.rpm
...

Теперь делаем себе жизнь проще:

1. Настраиваем репозитарий YUM.
2. Запускаем: root# yum update ffmpeg
3. В случае проблем получаем достаточно внятную диагностику и список пакетов, которые необходимо установить для удовлетворения "зависимостей". Обычно достаточно согласится с рекомендациями yum и все остальное делается без Вашего участие.
4. Вы пока можете занятся чем-то более полезным или приятным...
Улыбка

RSS-материал